User Tag List

Thanks Thanks:  0
Likes Likes:  3
Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Strange electrical quibble

  1. #11
    VIP-Member Sodburybungy's Avatar
    Join Date
    Jan 2017
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Life

    Engine : 1.8

    Year : 2004

    Default

    Quote Originally Posted by beavor-bob View Post
    Might be an idea to change that Relay, being partly out it may have been chattering & become damaged?
    Thanks. Yes, I agree. I'm still suspicious about that. It was a tangible finding so I'm going to replace the relay (small cost so no-brainer), and check the cd70 connection.

    MoT next week so if that doesn't fix I'll get them to check the alternator.

  2. #12
    VIP-Member Sodburybungy's Avatar
    Join Date
    Jan 2017
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Life

    Engine : 1.8

    Year : 2004

    Default

    OK. Got a new relay. Dealer part only so had to go to the Truro vx dealers. 6 quid so not a lot. However, no luck. Got some new removal pins to remove stereo and all connections look good, but reconnected everything to be sure. So it looks like an alternator glitch afterall. I'll get my local garage to check when I get home. The other alternative is the CD70 that was a bargain on ebay wasn't such a bargain..... Lol.

    Interesting though that the vx dealer said they sell a lot of starter relays, so they may be prone to problems. Not in my case though.

  3. Likes vectra ste liked this post
  4. #13
    VIP-Member Sodburybungy's Avatar
    Join Date
    Jan 2017
    Location
    Bristol
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Life

    Engine : 1.8

    Year : 2004

    Default

    OK. Really weird. After removing and refitting the CD70 I haven't had the fault again! But on the way back home when in cruise going up hill, I could feel and hear a slight RPM variability, not so much hunting but as if it was overshooting the required speed slightly, cutting back then accelerating again. Barely perceptible. Also going down hill in cruise normally I'd expect the car to accelerate under gravity but now seems to be pulling back (which is what an automatic does in my experience). Starting to be convinced the alternator is upsetting things.

    MoT Friday. I'll get them to check.

  5. Likes vectra ste liked this post
Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Strange Electrical Issues.
    By Lostate in forum Electrical & ICE (including SatNav)
    Replies: 8
    Last Post: 1st August 2014, 06:52
  2. Strange electrical probs
    By Jabbekot in forum Electrical & ICE (including SatNav)
    Replies: 11
    Last Post: 18th February 2014, 10:58
  3. Strange electrical problem - please read & help.
    By Vaux-Man-G in forum Electrical & ICE (including SatNav)
    Replies: 13
    Last Post: 7th September 2011, 08:46
  4. Strange electrical problem regarding radio controls on steering wheel
    By eaglepva in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 12th January 2011, 17:36
  5. strange dash electrical fault
    By lee866 in forum Electrical & ICE (including SatNav)
    Replies: 44
    Last Post: 29th June 2010, 17:56

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •