User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: dead slow vectra SRi 150cdti

  1. #1
    Regular Member
    Join Date
    Jan 2007
    Location
    Killyleagh
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default dead slow vectra SRi 150cdti

    My friend has complained that his car was sluggish, it has been on the diagnostic machine and it is clear. I told him about this site, but as he has no internet, I said I would throw a post open for help. The best way I can describe it after having driven it today is that the engine will only pick up revs at its own rate, if you floor the throttle, at idle, it gradually increases revs. I drove it in second gear at 20 mph and floored it and the same thing happened, I have driven 1.2 Corsa courtesy cars which pick up quicker. It is sort of like when you catch a turbo off boost, but the boost never comes, if you know what I mean. Any ideas?

  2. #2
    Regular Member
    Join Date
    Jan 2007
    Location
    morton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    any dash lights on mate ?

  3. #3
    On a Sabbatical
    Join Date
    Jun 2005
    Location
    Failsworth, Manchester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Sounds like a dodgy Swirl Valve matey.

  4. #4
    Regular Member
    Join Date
    Jan 2007
    Location
    morton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    why did VX not find that then ?

  5. #5
    Regular Member
    Join Date
    Jan 2007
    Location
    Killyleagh
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    No, all the lights went out as they should, thank you veccy22 , would the swirl vavle be able to by-pass the diagnostics? thank you AJA.

  6. #6
    On a Sabbatical
    Join Date
    Jun 2005
    Location
    Failsworth, Manchester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I believe a faulty swirl valve doesn't always cause the car to jump into Limp Home Mode, but it does make it run lumpy or reduce the power. Don't take my word for it though, go and have it checked matey.

  7. #7
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    AJA is correct, if won't always give a fault light.. it's a well know fault though so VX will know what you mean when you say you think it's the swirl valve..

    I hope he's still got warranty thou as it's not cheap if it's expired..

  8. #8
    Regular Member Jamie's Avatar
    Join Date
    Jun 2005
    Location
    Worcestershire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Is the swirl valve the same thing as the EGR valve..... I broke down yesterday with similar symptoms (AA were great and gave me a replacement car without quibble) and it all sorted today with a replacement EGR valve.

  9. #9
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    nope.. different parts Jamie...

  10. #10
    Regular Member
    Join Date
    Jan 2007
    Location
    Killyleagh
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thank you , the car still has warranty, but I kinda wonder if it could be a fault that you Guys have highlighted, not withstanding the fact that no fault is stored, why should/how can VX sort the problem when their plug in tells them nothing is wrong? I t would seem to me like " yes i know you can find nothing wrong, but my mate says......."

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. VVTI vectra really slow.
    By bowey in forum Engine & Drivetrain
    Replies: 11
    Last Post: 28th September 2012, 07:11
  2. Slow to pull away - dangerously slow to pull away (150cdti auto)
    By the1theycallthe1 in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 29th March 2012, 21:10
  3. Vectra c sri 150cdti backbox
    By robk6112 in forum Vectra C / Signum Car Chat
    Replies: 10
    Last Post: 6th March 2009, 17:30
  4. Vectra Elite 150cdti
    By amos in forum Cars for sale
    Replies: 2
    Last Post: 9th February 2009, 16:58
  5. 55 Vectra 150CDTI SRI Cutting Out
    By Pauleyuk in forum Troubleshooting
    Replies: 5
    Last Post: 24th May 2008, 13:16

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •