User Tag List

Thanks Thanks:  0
Likes Likes:  1
Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Vectra air blowers not blowing hard enough?

  1. #1
    New Member
    Join Date
    Nov 2015
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra air blowers not blowing hard enough?

    The air/heat blowers for my 05' vectra aren't very powerful.. Their strength on 4 (full) is barely what 1 (minimum) is on other cars... I've had the a/c looked at and that's now running properly just lack of air flow... The only thing that's missing is the air recirculation pump.. But the mechanic's I've spoken too can't say whether fitting one will solve the issue.. And since I never use the recirculation function, I don't want to pay out to sort this, if it doesn't fit the flow issue... So any idea's that'll help fix this would be greatly appreciated.. :-) it's cold when driving home from work when it's minus 2 outside... Even with the heaters on full!!!

    Sent from my D6603 using Tapatalk

  2. #2
    Regional Organiser - South something area HarrysDad's Avatar
    Join Date
    Jul 2014
    Location
    Camberley, Surrey
    Post Thanks / Like
    Mentioned
    95 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia A

    Trim : Sri

    Engine : A20NHT

    Year : 2009

    Mileage : 54323

    Default

    Whats the pollen filter condition like? Don't know if this would impede air flow but worth a look at it.
    Check HERE for upcoming meets/events

  3. #3
    Regular Member
    Join Date
    Nov 2012
    Location
    cumbernauld
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It's probably a bit of loose ducting air recirculation will blow air on and off. You just need to follow the ducting from the motor. It's just an actuator in the car that does the air recirculation. Take the ducting under the motor off put it on 4 see if the air pressure is coming out there if it us start looking for disconnected ducting to vents

    Sent from my GT-I9505 using Tapatalk

  4. #4
    Ex Vec-C Admin & Founder GARY3306's Avatar
    Join Date
    Jun 2005
    Location
    Ashington, Northumberland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I'm with Harrysdad. A choked pollen filter will most definitely cause this. Easiest and cheapest fix too if it is that. When I bought my daughter her Astra, the heater blower was like a negligible breeze. Took the pollen filter out, and I have never seen one as blocked and black as this one was. Heater blower works as it should now.
    [SIGPIC]VX<font color=Red>R</font> with added Courtenay <img src=https://www.vectra-c.com/forum/images/smilies/biggrin.png border=0 alt= title=Big Grin class=inlineimg />

  5. #5
    Regional Organiser - South something area HarrysDad's Avatar
    Join Date
    Jul 2014
    Location
    Camberley, Surrey
    Post Thanks / Like
    Mentioned
    95 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia A

    Trim : Sri

    Engine : A20NHT

    Year : 2009

    Mileage : 54323

    Default

    Quote Originally Posted by GARY3306 View Post
    I'm with Harrysdad. A choked pollen filter will most definitely cause this. Easiest and cheapest fix too if it is that. When I bought my daughter her Astra, the heater blower was like a negligible breeze. Took the pollen filter out, and I have never seen one as blocked and black as this one was. Heater blower works as it should now.
    My Dads focus st2 was the same, really bad air flow even on the highest setting that's why I mentioned it. I changed his pollen filter and it turned out to be an aftermarket one that had folded inside the housing partially blocking it. Was a pain in the butt to change as the glove box had to come out along with the fuse panel and lots of bolts as its hidden behind the center console in the dash on a focus.
    Check HERE for upcoming meets/events

  6. #6
    Ex Vec-C Admin & Founder GARY3306's Avatar
    Join Date
    Jun 2005
    Location
    Ashington, Northumberland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I know all about Focus pollen filters. What a pain
    [SIGPIC]VX<font color=Red>R</font> with added Courtenay <img src=https://www.vectra-c.com/forum/images/smilies/biggrin.png border=0 alt= title=Big Grin class=inlineimg />

  7. #7
    Regional Organiser - South something area HarrysDad's Avatar
    Join Date
    Jul 2014
    Location
    Camberley, Surrey
    Post Thanks / Like
    Mentioned
    95 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia A

    Trim : Sri

    Engine : A20NHT

    Year : 2009

    Mileage : 54323

    Default

    Quote Originally Posted by GARY3306 View Post
    I know all about Focus pollen filters. What a pain
    Haha, would love to meet the guy who thought "I know, lets put a serviceable part where Jo Public cant get to it without being a contortionist and disassembling half there car"
    Check HERE for upcoming meets/events

  8. #8
    Full Member Allydfr's Avatar
    Join Date
    Mar 2012
    Location
    N.I
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Sri


    Engine : 1.8vvt

    Year : 2006

    Default

    Mine was the same when i bought it! As said i changed the pollen filter in mine and was shocked at the difference it made. Deffinitely worth a bash first

  9. #9
    New Member
    Join Date
    Nov 2015
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Will definitely check out the ducting for it.. And let you know.. Cheers guys.. :-)

    Sent from my D6603 using Tapatalk

  10. #10
    New Member
    Join Date
    Jan 2021
    Location
    Turkey
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Vectra 2011

    Trim : Vectra 2011

    Engine : 1.3

    Year : 2021

    Default

    I think there will be a problem with the pollen filter. It would be best to take the air blower to the nearest repair shop.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Blowers not blowing hot on vectra CDTI
    By roosie in forum General Motoring Chat
    Replies: 6
    Last Post: 22nd February 2014, 13:37
  2. Blowers blowing very little air!
    By elfrider in forum Bodywork & Interior
    Replies: 7
    Last Post: 12th January 2014, 21:21
  3. Blowers not blowing hot
    By john506 in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 11th February 2013, 21:04
  4. hard blowing noise from vec c v6 cdti v6
    By v6 sri diesel in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 1st May 2011, 00:04
  5. blowers and ac blowing hot air
    By Baz4u2me in forum Vectra C / Signum Troubleshooting
    Replies: 2
    Last Post: 27th January 2010, 15:17

Visitors found this page by searching for:

vectra c blower not powerful

vectra c blower not powerful site:www.vectra-c.com

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •