User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Am I getting ripped off?

  1. #1
    Regular Member
    Join Date
    Mar 2007
    Location
    Australia
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Am I getting ripped off?

    I had a wheel bearing problem as it was making a lot of humming noise.
    Anyhow, when I took it to the dealers, they said that they had to replace the bearing hubs as well.. which is very costly.

    It is common to replace the hub as well rather than the wheel bearing itself?

    Help! Or my credit card is going to melt helplessly!

  2. #2
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    it's a massive sealed unit mate..gone are the days of just changing the bearing races, now it's a huge chunk of metal that includes the ABS hub and pickup as well.. they sell for £100 from VX or £70 for a copy over here..not a huge job to fit either..takes about 2 hrs..

  3. #3
    Regular Member
    Join Date
    Mar 2007
    Location
    Australia
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default RE:

    Yes.. that's what I've been told and fixed both left and right front wheels..

    Just a query though, what are the things that causes the wheel bearing problems? so that I can try and prevent it from happening again...

  4. #4
    Regular Member david.aka.judas's Avatar
    Join Date
    Nov 2006
    Location
    Suffolk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    this happened to me about 2 weeks ago.

    I thought it was the wheel bearing but it turned out to be a front hub.

    the humming started at about 35mph and the got progressively louder until about 70mph.

    luck though coz it was covered, ul if you have to pay, but i would say they where right.

    my car has done 70k if that helps.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ripped of by ats
    By tangoman in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 18th April 2012, 18:13
  2. Am I being ripped off
    By sebadee in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 17th January 2011, 14:42
  3. Ive been ripped off..
    By siz1 in forum General Chat
    Replies: 25
    Last Post: 26th November 2010, 09:42
  4. Have I been ripped off ?
    By headache56 in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 27th January 2010, 18:31

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •