User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Heater Problems ???

  1. #1
    Regular Member suj786's Avatar
    Join Date
    Sep 2005
    Location
    glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Heater Problems ???

    the heaters gone funny on my 02 veccy. It only gives out heat properly sometimes and at all other times the heat is very slightly warm, also when i switch the fan to full (e.g 4 on the dial) there is a loud click from behind the glove box and then the whole dash vibrates like an old fridge.

    I mentioned it to the dealer while it was in for a service and they wanted £215 just to have a look, they mentioned that something might have been stuck in the heater matrix and that they had to get the dash off to get to it !

    I've just had a big ICE install and it involved taking the glove box and other bits of the dash out the car. while the glove was off i think i spotted the heater matrix, the auto electrician who put my system in had a quick look at it but couldn't find anything.

    Has anybody else had this problem and will it really cost £200+ to fix.

  2. #2
    [Ex]Admin Duncan's Avatar
    Join Date
    Jun 2005
    Location
    East Sussex
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    £215 just to have a look!!! WTF are they on!? Take it somewhere else that isn't on drugs!!! LOL

    D

  3. #3
    On a Sabbatical
    Join Date
    Jun 2005
    Location
    Failsworth, Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sound advice that (above)

  4. #4
    Regular Member Harry's Avatar
    Join Date
    Aug 2005
    Location
    Uxbridge, London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    nope...not experienced anything like this, ever....thankfully!!

    when you say "sometimes" what do you mean? have you noticed a pattern to when it does and doesn't work or is it completely random?

  5. #5
    Regular Member suj786's Avatar
    Join Date
    Sep 2005
    Location
    glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    its just completely random. i used to switch the engine off and restart to fix it, but even that doesnt work anymore. its really irritating when the windscreen is misted, takes ages to demist.

    I'm wondering if i could just buy a heater matrix from a scrappy and change it with my current one,

    any thoughts on this ?

  6. #6
    Regular Member Lloydy's Avatar
    Join Date
    Aug 2005
    Location
    Newbury
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    This may be a total red herring, but when the heater in the wife's Corsa refused to work I checked the water etc and found it needed a good top-up. After that the heater worked fine! Might be worth a check on the coolant level, just in case...

  7. #7
    Regular Member SignumPhil's Avatar
    Join Date
    Jun 2005
    Location
    Luton, Beds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    If you're getting vibration, it suggests that something's wrong with the heater fan, either something attached to it, or a blade broken off. No idea how you get to the bloomin' thing, though.

    Phil

  8. #8
    Regular Member suj786's Avatar
    Join Date
    Sep 2005
    Location
    glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    checked the water coolant level, seems to be fine, its just been serviced by vauxhall they couldnt see any problem on the surface, so i assume it must be quite a major fault somewhere. its gettin very cold now up here in glasgow and lack of heater is really biting.

    I'm just going to take the heater apart, c what i can find, should take up most of the weekend

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Heater fan problems
    By woodley Vectraman in forum Bodywork & Interior
    Replies: 6
    Last Post: 14th July 2012, 20:43
  2. Heater Problems, And then some.
    By Deathtopia in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 9th February 2011, 09:58
  3. heater problems
    By pete w in forum Bodywork & Interior
    Replies: 2
    Last Post: 12th December 2010, 21:28
  4. heater problems!!
    By dazza2393 in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 11th July 2010, 08:32
  5. heater problems
    By blackcountryroy in forum Bodywork & Interior
    Replies: 10
    Last Post: 16th January 2010, 19:38

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •