User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: fao anyone with forge dump valve

  1. #1
    Regular Member icetrix's Avatar
    Join Date
    Jan 2007
    Location
    bangor
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default fao anyone with forge dump valve

    as i mentioned in another thread i purchased a forge dv, i was getting a good loud ppssssst the first few days but no its no louder than the standard recir valve, jus took it apart to clean it and noticed mine has a yellow spring in it which according to forge is rated 15-23 psi, anyone who has one and taken it apart could u tell me what colour your spring is, as i think it should be a green one rated 5-15psi

  2. #2
    Regular Member Modifications's Avatar
    Join Date
    Nov 2006
    Location
    Sheffield
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    it should be green bud, never checked mine but when i ordered it they did say it will come with a green spring

  3. #3
    Regular Member icetrix's Avatar
    Join Date
    Jan 2007
    Location
    bangor
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    i emailed forge and they said the spring should be yellow, i am now quite confused, unless they think its for the vxr, what does the vxr boost at?

  4. #4
    Regular Member icetrix's Avatar
    Join Date
    Jan 2007
    Location
    bangor
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    ok ive conducted an experiment, i disconnected the vacuum pipe for my boost gauge and the dump valve now works, still no wiser to why, am thinkin maybe the difference in vac to and from the gauge is stopping the dump valve from working

  5. #5
    Regular Member Ian's Avatar
    Join Date
    Oct 2005
    Location
    York
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    try shifting the take off point for one or the other to somewhere else. try the fuel pressure regulator. It does seem odd though as the boost gauge is a sealed unit and whilst it does increase the volume slightly, its only a tiny amount. I wonder if that tiny amount is enough not to put enough pressure on the DV spring?

  6. #6
    Regular Member icetrix's Avatar
    Join Date
    Jan 2007
    Location
    bangor
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    ok spoke to forge today, they said the yellow spring is correct (15-23psi) and i told them it works without the boost gauge connected and they said that their dump valve was degined to work on an uninterupted vac line, anyway came home and found they had sent me the green spring (rated 5-15psi) put it in the dump valve with the boost gauge connected took her up the road, boosting at 10psi change gear pppsssst, happy days, dissconnected the boost gauge even louder pppssst, so i think i have it all sorted now, am still convinced it was supposed to come with the green spring in the first place

  7. #7
    Regular Member Ian's Avatar
    Join Date
    Oct 2005
    Location
    York
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    I would agree with you judging by the ratings on the springs. I wouldnt of though a gauge would "interupt" the vacumn to that extent. Glad youve got it sorted, at least the saab engines work with a dump valve!! (better tha vauxes own z20!!)

  8. #8
    Regular Member dervdoc's Avatar
    Join Date
    Dec 2006
    Location
    Co.Armagh
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Thumbs up

    Quote Originally Posted by icetrix View Post
    ok spoke to forge today, they said the yellow spring is correct (15-23psi) and i told them it works without the boost gauge connected and they said that their dump valve was degined to work on an uninterupted vac line, anyway came home and found they had sent me the green spring (rated 5-15psi) put it in the dump valve with the boost gauge connected took her up the road, boosting at 10psi change gear pppsssst, happy days, dissconnected the boost gauge even louder pppssst, so i think i have it all sorted now, am still convinced it was supposed to come with the green spring in the first place
    good job m8

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2.0 DTI dump valve ??
    By christianrickhuss in forum Diesel Engine related
    Replies: 18
    Last Post: 26th April 2013, 17:55
  2. Forge dump valve 2.0t
    By blue estate in forum Parts for sale
    Replies: 1
    Last Post: 3rd October 2009, 09:26
  3. Forge Dump Valve
    By blue estate in forum Parts for sale
    Replies: 4
    Last Post: 28th April 2009, 16:29
  4. Replies: 23
    Last Post: 6th March 2009, 09:00

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •