User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: strange rattle around 1500rpm?? 1.8 vvti 06

  1. #1
    Regular Member
    Join Date
    Mar 2007
    Location
    huddersfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default strange rattle around 1500rpm?? 1.8 vvti 06

    hi,
    just wondering if a 1.8 vvti should kind of rattle around 1500rpm? ive had a few probs so far with my new car so this rattle is the least of my probs really just curious as to what it could be. the car seems to struggle and make a rattling from under the bonnet until the revs pick up. only noticed it when i tried to climb a hill in a too high gear but now ive heard it it does it all the time as soon as the rev counter is around 1500, what ever gear i am in??
    i thought it could be the air box rattling coz its trying to suck more air through but when parked up with the bonnet up i cant get it to make the noise. i have put in a k&n panel filter and done the air box mod and the car revs ok past 2000rpm but seems to struggle and make this noise under that.
    its booked in to check the clutch and flywheel next week (which should be replaced) .could these being faulty be the cause of my rattle?

    if i took it to vx i know they will just laugh at me and say im being stupid so any insight into this would be appriciated and if i am being stupid please feel free to say so.
    thanks in advanced.

  2. #2
    Regular Member robzc's Avatar
    Join Date
    Mar 2007
    Location
    South West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds to me like pinging, usually due to the timing being wrong for the load on the motor. As you can't do anything about the timing, it could be the knock sensor not working properly. I'm not sure how to check this, but I'm sure someone on the site does!

  3. #3
    Regular Member
    Join Date
    Mar 2007
    Location
    huddersfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    ive never even heard of a knock sensor, i will do some research. do you know what the knock sensor does?
    cheers for replying so fast m8.

  4. #4
    Regular Member robzc's Avatar
    Join Date
    Mar 2007
    Location
    South West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused

    It detects when a motor is about to knock - the pinging sound you can hear - and alters the timing to prevent this. The system retards the timing to get the best performance & economy, but retarding the timing too much causes this pinging / knocking & the knock sensor should detect this before this happens & adjusts the timing accordingly to prevent it.

    Of course, this could be total BS, this is what I had wrong on a 1990 Opel!

  5. #5
    Regular Member
    Join Date
    Mar 2007
    Location
    huddersfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i haven't had any management lights on so how would i be able to tell if the sensor was playing up?
    if vx do a diagnosis check would the faulty sensor show up?
    dont fancy paying for a diagnostic when nothing is wrong.
    sounds like that could be the problem.
    nice one m8.

  6. #6
    Regular Member robzc's Avatar
    Join Date
    Mar 2007
    Location
    South West
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused

    No idea how to check it mate, sorry. Hopefully someone else here might??

  7. #7
    Regular Member Kcs's Avatar
    Join Date
    Feb 2007
    Location
    Tamworth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Not sure where the knock sensor is on the Vecy, it was located on the front of the engine block on the Mondeo, you could just unscrew it and stick a new one in !

  8. #8
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    IF it has a knock sensor fitted and it was still letting it 'pink', then there would be a warning light flagged up..

    if the noise worries you, then can i suggest you return the car to the dealers and ask them to look at it.. fault light or not..Many faults do not present a light.. it's only there to show electrical issues and not mechanical ones..

  9. #9
    Regular Member
    Join Date
    Jun 2005
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Try running on V-power petrol, to see if the pinking goes.

  10. #10
    Regular Member
    Join Date
    Mar 2007
    Location
    huddersfield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i will try that. if it does go, does that mean i have to run it on v-power all the time or is there a problem with something?

    the reason why i haven't taken it to the dealers yet is because i might be paranoid (because i only got the car a month ago) and all might be normal. that is why i am asking you guys if any of my possible symptoms are common.

    cheers for the help.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Very strange noise from 1500rpm
    By ads3 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 19th December 2011, 22:20
  2. 1.8 VVTI Cold Rattle ..... Again
    By robdd1 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th July 2011, 12:20
  3. VVTi Small Rattle on 1st Start
    By robdd1 in forum Engine & Drivetrain
    Replies: 14
    Last Post: 15th April 2011, 21:09
  4. dmf rattle....very strange?
    By big rich in forum Engine & Drivetrain
    Replies: 12
    Last Post: 26th March 2010, 22:00
  5. Strange rattle sound on 3,000 rpm.
    By Stevie-B in forum Engine & Drivetrain
    Replies: 5
    Last Post: 29th February 2008, 01:44

Visitors found this page by searching for:

vectra c 1.8vvti starved of fuel or air not running right

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •