User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: Turbo Lag

  1. #1
    Regular Member installer's Avatar
    Join Date
    Jul 2005
    Location
    Nottingham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Turbo Lag

    This has been mentioned a little before this but only in threads not a thread on it.
    I`ve had my 1.9 CDTi (150) Estate for 18 months and still can`t get over how dead it is below 1800ish rpm until turbo kicks in.
    I am correct that everyone elses is the same?
    Is the cure a remap @ VXR or Courtenay for example.
    If you don`t bring the revs up you`d get killed at some point I`m sure - which until I got used to it happend a few times.Me screaming "come on" then 1800ish rpm and phew what a relief.
    So a fair statement is that the 1.9 CDTi needs keeping on the boil so to speak?
    Any views or thoughts on this.

  2. #2
    On a Sabbatical
    Join Date
    Aug 2006
    Location
    member of the smoke patrol 230bhp+
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    thats just what a turbo is like
    if you had a smaller turbo this wouldnt happen as it would spin up faster but with a smaller turbo come less power.
    a smaller turbo would make it pull like a train upto about 2500 rpm then its all gone its just a trade off .
    this is why company are playing around with 2 turbo's
    1 small turbo to work at low presser and to pull low down then the larger turbo come in to do the rest.

    id think vauxhall where doing one a bi-turbo 1.9 cdti engine soon im shore there is a link on the site somwhere about the vectra with the new engine .

  3. #3
    On a Sabbatical
    Join Date
    Aug 2006
    Location
    member of the smoke patrol 230bhp+
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    to solve all the lag from a tubro jag go a diffrent way and bolt a supercharge to there engines
    no lag at all but this takes power to run them

  4. #4
    Regular Member amos's Avatar
    Join Date
    Mar 2006
    Location
    s,wales
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I had the same with mine, I put K&N on made it better and then tuning box runs like dream from low down revs and increase economy.

  5. #5
    Regular Member Kcs's Avatar
    Join Date
    Feb 2007
    Location
    Tamworth
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Hi, mine had a small amount of lag below 1800 rpm but i improved it greatly when i dropped a K&N filter in and did the box mod ! one thing i did do which in my experience didn't help, was to disconnect the battery leads ! this made the lag reappear. Once the K&N was fitted it took about three days for the ecu to adapt. cheers Kcs

  6. #6
    Regular Member installer's Avatar
    Join Date
    Jul 2005
    Location
    Nottingham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Another way of expressing the question is -

    is the lag a characteristic of the CDTi

  7. #7
    Regular Member installer's Avatar
    Join Date
    Jul 2005
    Location
    Nottingham
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by amos View Post
    I had the same with mine, I put K&N on made it better and then tuning box runs like dream from low down revs and increase economy.
    Quote Originally Posted by Kcs View Post
    Hi, mine had a small amount of lag below 1800 rpm but i improved it greatly when i dropped a K&N filter in and did the box mod ! one thing i did do which in my experience didn't help, was to disconnect the battery leads ! this made the lag reappear. Once the K&N was fitted it took about three days for the ecu to adapt. cheers Kcs
    Did the airbox mod when first got it in 2005.(However have got new airbox lid as I had originaly removed the trumpet that goes on the the MAF sensor.)
    Took my K/N out as the MAF was getting coverd in filter oil and the numerous storys of excees oil damaging MAF sensors.So I now replace my standard filter every 6 months.
    Think remap is far better than box for long term reliabilty as plan to keep it a while (or can`t afford to replace it)

  8. #8
    Regular Member Kcs's Avatar
    Join Date
    Feb 2007
    Location
    Tamworth
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    I think it is on most diesels, but manufacturers will be using two turbo's on most cars soon.

  9. #9
    Regular Member Kcs's Avatar
    Join Date
    Feb 2007
    Location
    Tamworth
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Yes the oil can be a prob, got the hair dryer on mine first !

  10. #10
    Regular Member Kcs's Avatar
    Join Date
    Feb 2007
    Location
    Tamworth
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    They don't tend to be too bad from K&N, its when people re charge them, they put too much oil on !

Page 1 of 4 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 19
    Last Post: 6th September 2014, 13:54
  2. Turbo Technics Hybrid turbo details.
    By nutron in forum Diesel Engine related
    Replies: 13
    Last Post: 28th February 2011, 22:57
  3. TD04L14T turbo for Z20NET (2.0 turbo)
    By Caveman_nige in forum Parts for sale
    Replies: 3
    Last Post: 10th October 2010, 13:23
  4. Turbo Help
    By CDTi-SRi-Matt in forum Engine & Drivetrain
    Replies: 5
    Last Post: 12th February 2010, 11:42
  5. is it possible to change 2.0 dti turbo to 2.2dti turbo
    By EURO G in forum Engine & Drivetrain
    Replies: 17
    Last Post: 22nd October 2008, 07:35

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •