User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: Changed airfiler, part of the MAF sensor was broken

  1. #1
    Regular Member simac's Avatar
    Join Date
    Sep 2006
    Location
    Wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Changed airfiler, part of the MAF sensor was broken

    Well, I say MAF sensor because I think that's the sensor on the top of the air box.

    I took the large intake pipe off to change the air filter and noticed some plastic inside the senor. It's like a plastic "spiders web", the opposite side to the mesh filter just before the sensor connects to the pipe. Part of it was broken and loose, after thinking about it I decided to remove it rather than risk small bits braking off and being sucked in to the engine

    It looks like it's only there to stop the delicate probes in the sensor being touched, does anyone know if it has another use ? It starts and runs fine with no warning lights or anything ......

    Cheers guys, could really do with putting my mind at rest

  2. #2
    Regular Member Ian's Avatar
    Join Date
    Oct 2005
    Location
    York
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Yep your right on all counts. But I would look into getting a new one. An old member did this - but removed it for perfromance reasons - and ended up buying a new MAF sensor. The fact that is broken may tell you its there for a reason.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. changed my outside temp sensor
    By tolly in forum Vectra C / Signum Troubleshooting
    Replies: 11
    Last Post: 13th January 2012, 10:01
  2. Boost Sensor Broken?
    By quarkrad in forum Engine & Drivetrain
    Replies: 5
    Last Post: 12th October 2011, 08:27
  3. Has anyone changed this part of the grill
    By Shogun in forum Styling
    Replies: 12
    Last Post: 14th September 2011, 18:30
  4. Broken brake pad sensor
    By mishima in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 30th January 2010, 00:08

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •