User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Fault code P0638

  1. #1
    Regular Member
    Join Date
    Feb 2007
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Fault code P0638

    Hi everyone,
    I'm new to the forums and really hope someone can help. i have a 3 1/2 year old signum elegance 2.2 tdi and the car/spanner yellow light keeps coming on with a resulting loss of power. the car is out of warranty now (typical !) and our local friendly mechanic has run a fault test on it at no charge (what a nice man). The fault code that comes up is P0638 which he says will be something to do with the throttle etc. but as it is only an intermittant fault it will be difficult , and probably expensive, to trace exactly what the problem is. It is getting much more frequent tho and is getting to the point that it's a gamble if you'll make it to/from your destinatio.

    has anyone else had similar problems? or know more specifically what might be causing this.

    Very gratefull for any advice.

    thanks

    Eileen

  2. #2
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    P0638 relates to the throttle actuator..Cars like these don't have a cable from the pedal to the engine anymore, there's an electonic device which does the job for us..the fault is saying it's control value is out of line..

    This will need careful examination by a vehicle elctronics expert to see if it's getting the correct signals..BUT as a start the mechanic could remove the throttle butterfly assembly to see if it's all caked up inside and if that is restricting it's movements...

  3. #3
    Regular Member
    Join Date
    Feb 2007
    Location
    Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have the same intermittent problem with my vectra estate - three trips to the main dealer and still no solution!

  4. #4
    Regular Member
    Join Date
    Feb 2007
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Gsi3.2 View Post
    P0638 relates to the throttle actuator..Cars like these don't have a cable from the pedal to the engine anymore, there's an electonic device which does the job for us..the fault is saying it's control value is out of line..

    This will need careful examination by a vehicle elctronics expert to see if it's getting the correct signals..BUT as a start the mechanic could remove the throttle butterfly assembly to see if it's all caked up inside and if that is restricting it's movements...

    Thanks Mark,

    Car is going in to the mechanic tomorrow and will mention the throttle actuator to him. I've told him about the advice received about the butterfly assembly and he's asked me to print it out and he will check it. I'll keep you posted about what happens

  5. #5
    Regular Member
    Join Date
    Feb 2007
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Welsh Paul View Post
    I have the same intermittent problem with my vectra estate - three trips to the main dealer and still no solution!

    What did they say the problem was and how did they try to fix it? I'll let you know if I have any luck.

    Eileen

  6. #6
    Regular Member
    Join Date
    Feb 2007
    Location
    Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    They are unable to find any fault with the vehicle...?

  7. #7
    New Member
    Join Date
    Sep 2007
    Location
    EAST KILBRIDE
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default similar problem

    hi Eileen,

    I have a similar problem too. I had the car serviced at Arnold Clark last week, the "spanner" light was coming on now and again, they cleaned out the throttle housing and advised me that I need a new throttle control valve. I have never heard of this part, and previously the problem I was having was the EGR valve which seems a very common fault with these cars. Mine is a 4 year old 2.2dti Elegance Signum.

    If I find out more I will let you know, and vice-versa!!


    Quote Originally Posted by eileeng2 View Post
    Hi everyone,
    I'm new to the forums and really hope someone can help. i have a 3 1/2 year old signum elegance 2.2 tdi and the car/spanner yellow light keeps coming on with a resulting loss of power. the car is out of warranty now (typical !) and our local friendly mechanic has run a fault test on it at no charge (what a nice man). The fault code that comes up is P0638 which he says will be something to do with the throttle etc. but as it is only an intermittant fault it will be difficult , and probably expensive, to trace exactly what the problem is. It is getting much more frequent tho and is getting to the point that it's a gamble if you'll make it to/from your destinatio.

    has anyone else had similar problems? or know more specifically what might be causing this.

    Very gratefull for any advice.

    thanks

    Eileen

  8. #8
    Regular Member
    Join Date
    Feb 2007
    Location
    Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Smile Fault repair

    Mine turned out to be a boost pipe that had split, the stealers replaced the part for about 80 - which did not seem to bad to me?

    To be fair the dealer was very good this time, kept me informed etc etc - the first time I have had a positive experience with a VX dealer.

    They said it is a very very common problem!!!

  9. #9
    Regular Member Steel's Avatar
    Join Date
    Feb 2008
    Location
    Sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Sri

    Engine : Z19DTH

    Year : 2005

    Default

    What sometimes happens on fly by wire systems is that the potentiometer (thottle sensor) track wears, probably more likely where the vehicle has been driven at constant speeds for long periods of time. This can cause erratic signals as the feed from the potentiometer drops out as the accelerator passes the broken bit of track. This often causes little or no problem during driving but can cause a fault code to be stored because the ECU has picked up an incorrect signal when it didn't expect it. The only real way to test this is with an oscilloscope as it will probably drop out and come back in too quickly to be picked up on a multimeter.

  10. #10
    VIP-Member superstuper's Avatar
    Join Date
    Dec 2006
    Location
    Trieste, Italy
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Vectra C

    Trim : Estate F35, Elegance

    Engine : Y22DTR

    Year : 2004

    Default

    Faulty throttle body. I need to replace them on my 2004 2.2 DTI.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fault code P0638 2.2 DTi o4 plate
    By Ian666 in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 10th February 2012, 18:16
  2. Fault Code P0638
    By Micknal in forum Engine & Drivetrain
    Replies: 0
    Last Post: 10th November 2011, 15:22
  3. Fault code P0638
    By Micknal in forum Engine & Drivetrain
    Replies: 0
    Last Post: 9th November 2011, 17:43
  4. Fault code P0638
    By Micknal in forum Engine & Drivetrain
    Replies: 0
    Last Post: 9th November 2011, 17:41

Visitors found this page by searching for:

p0638 opel vectra c

p0638 opel vectra c 19th

p0638

p0638 опелp0638 vauxhalldefaut p0638 opel vectra cOpel DTC P0638-07opel vectra c p0638opel vectra 2.2 erro p0638po638 vecta fixp0638 opel signumb2.2p0638 opelp0638 vectra c 2.2p0638 opel vectra c numberp0638-04 opeldti p0638vectra c error p0638-04 P0638 - 04 y22dtrOpel P0638p0638 vauxhall y22dtrp0638 опел not startvectra c p638Opel P0638(07)vauxhall vectra 2000dti code p0638

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •