User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Spanner light at low revs?

  1. #1
    Regular Member ChrisFox's Avatar
    Join Date
    Feb 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Unhappy Spanner light at low revs?

    Hi all, I am new to the forum, just discovered the website yesterday!
    I have a 2003 53 Vectra 2.2DTI SXI. Recently I have noticed an intermittent annoying problem, and am wondering if anyone has any advice.
    Sometimes when driving along, if I am in a high gear but at lower revs, for no reason the spanner light comes on and the car drops to half power and I can't go over 50mph. If I stop, switch off then back on the car is fine again. I have taken it into the local vx garage, but apart for telling the light had been on (I could have told them that!) they could not find any faults.
    Has anyone experienced this, or know what it is?

  2. #2
    Regular Member m8internet's Avatar
    Join Date
    Dec 2006
    Location
    Cumbernauld, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like the engine is going into safe mode, restricting the revs to about 1500 rpm to prevent engine damage
    This is normally caused by cranshaft sensor failure, but that should be logged on the ECU and read on TEC2
    if the VX dealership can't read and diagnose the fault, wait until the fault reoccurs and try a different dealership

  3. #3
    Regular Member parapaul's Avatar
    Join Date
    Jul 2006
    Location
    127.0.0.1
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I thought the fault codes were stored on the ECU for the next 25 starts, or something like that, and only cleared if the same fault doesn't happen again within that time.

    So the dealer should be able to find something....if they actually looked.

    And yes, it sounds like limp mode.

  4. #4
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by parapaul View Post
    I thought the fault codes were stored on the ECU for the next 25 starts, or something like that, and only cleared if the same fault doesn't happen again within that time.

    So the dealer should be able to find something....if they actually looked.

    And yes, it sounds like limp mode.
    You are quite correct.. if the EML comes on, it is stored for a period..Tech2 will be able to read it, but it does depend on the skill of the operative..

  5. #5
    Regular Member Caterman's Avatar
    Join Date
    Aug 2005
    Location
    Here, there and every where!
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Elite

    Engine : 3.2 V6

    Year : 05

    Default

    Quote Originally Posted by Gsi3.2 View Post
    ......... but it does depend on the skill of the operative..
    .....and we all know what most of them are like Mark

  6. #6
    New Member
    Join Date
    Jan 2007
    Location
    Portsmouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Spanner light at low revs

    Hi Chris,

    Just reading your problem with the spanner light at low revs. Did you ever fix it?

    I've got a 03 plate 2.2DTI SRi and have had the same problem recently. When I towed my caravan at low revs the light comes on, so I have to keep it about 2000rpm.

    I've also noticed now, that some times it come on when it's on idle, but then goes off again.

    I've spoken to the VX dealer, but they said there's no guarantee that they can fix it, unless it stays on all the time.

    Regards

    Paul

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 30000 revs spanner light .limp mode .vectra 2.0 dti 2004
    By davemander in forum Engine & Drivetrain
    Replies: 7
    Last Post: 19th February 2013, 00:07
  2. Reluctant start, revs dipping and car with spanner light
    By coldo in forum Engine & Drivetrain
    Replies: 15
    Last Post: 12th November 2012, 23:51
  3. Spanner light and loss of power at low revs
    By Marky in forum Engine & Drivetrain
    Replies: 4
    Last Post: 29th April 2010, 16:34
  4. Spanner light on at low revs.
    By arnie_barney in forum Troubleshooting
    Replies: 2
    Last Post: 13th December 2009, 11:39
  5. 2.2dti only revs to 2600 rpm- spanner light on
    By nutty0069 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 25th January 2009, 15:42

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •