User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: Electrical problem; power steering or is it?

  1. #1
    Regular Member
    Join Date
    Jun 2009
    Location
    Brighton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Electrical problem; power steering or is it?

    Hi chaps had a very weird problem with my 2006 Vectra C estate the other day. Driving along at night after about 10 miles when, radio went off as did all interior lights etc. (windows would not open, indicators not working). The head and tail lights stayed on but power steering stopped working as well. Whenever I slowed down (braked), they all momentarily came back on. As soon as seemed to accelerate; off they all went. Also if a turned ignition off and started engine again all came back, but as soon as I started off (i.e. engine speed increased) it all went off again.

    It turned out I had RAC home start so i thought Iíd get them out to have a look. Within 1 min he said I had an alternator problem and showed me 16 V across the battery so I thought that must be it. This was a bit odd as the alternator was only 18 months old. However, i did get one of those cheap RTX alternators and Iíve read that they are crap and can fail after a year. Later that night I heard that sort of mini car alarm noise you get from these cars (not the full blown alarm). I didnít think it was my car so ignored it. In morning I had a flat the battery thatís when I realised it was my car alarm the night before doh...... (The battery is a 1 year old and a heavy duty BOSCH thing). Today I jump started it off the wife's Corsa after half hour and it seems to be charging at around 13.5 - 14 V; normal. I took it for a good run at all speeds and the fault has not reoccurred? Whatís going on? Can an alternator behave like this and give me all these symptoms?

    Any comments would be gratefully received, cheers, Neil

  2. #2
    Regular Member
    Join Date
    Jun 2009
    Location
    Brighton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Well I didn't get any reply so had to go with RAC advice as called them out a 2nd time. He showed me it was 12.32 A (low) charging, even dropped with lights on, heater blower, rear window etc. I noted after that when you measure leakage through battery ground (putting my DVM in series between battery -ve terminal and battery earth cable) i was getting 5 A !! This seems huge. I heard that failing diodes in the rectifier part of the alternator can fail and leak the battery to ground so I put it down to this. Now then. I had a brand new Lucas alternator fitted today and it charges at a nice 14 V but when I did the leakage test I got 2 A now?? This still seems high. Has anyone measured the residual leakage on a vectra they can remember? I would imagine it could have clock and sleeping ECM/electronics and be in the mA range not 2 A?? I would really appreciate any experiences here please??

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Electrical Hydraulic Steering Light Problem
    By Devildriver in forum Electrical & ICE (including SatNav)
    Replies: 15
    Last Post: 8th July 2011, 07:32
  2. Strange electrical problem regarding radio controls on steering wheel
    By eaglepva in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 12th January 2011, 17:36
  3. Power Steering, Electrical or Belt Driven?
    By Waterboy in forum Engine & Drivetrain
    Replies: 1
    Last Post: 5th February 2009, 23:41
  4. Power Steering Problem
    By marcel1 in forum Vectra C / Signum Troubleshooting
    Replies: 1
    Last Post: 23rd August 2008, 15:39
  5. Power Steering Electrical Power Drain
    By AntB in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 1st November 2007, 16:03

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •