User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: 0093 Fault Code, Dealer Says Not Easy to Diagnose

  1. #1
    Regular Member
    Join Date
    Apr 2012
    Location
    mk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused 0093 Fault Code, Dealer Says Not Easy to Diagnose

    Well after 30,000 miles of blissful driving I have been hit with the amber light with car and spanner on the dash. This happened a few days ago resulting in a distinct lack of power. The car still drives but at a reduced level of power. Took to dealer who read code and advised BCM needs resetting according to their computer. Twenty minutes after getting the car back in the afternoon same problem, of course dealer closed by then. Took the car back next morning where the fault was still evident although there was no engineer available to view the information live, (this is at a main dealer). In the afternoon went back for the car and was advised that they took vehicle out three times and could not replicate the fault but 0093 was still there on pedal test, granted it drove as it should for day and a half and fault is now back today. Rang dealer for appointment next week and was advised that they may need car for few days as difficult to diagnose 0093 fault code. (surely not I said, is this just trial and error)?

    Of course once engine is turned off everything resets although the pedal test still reveal 0093 code. When the fault occurs, on idle the engine revs up to say 1000 rpm, pressing the brake pedal reduces the revs to normal. Anyone experienced this and what area could we be looking at. Car is a 57 plate Z30DT V6 auto.

    Thanks members for your thoughts.

  2. #2
    North West - Assistant RO Woody's Avatar
    Join Date
    May 2012
    Location
    North West (Warrington)
    Post Thanks / Like
    Mentioned
    234 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C 3.2 Elite Estate Auto Facelifted

    Trim : Elite with loads of "Extras"

    Engine : 3.2 Z32SE

    Year : 2004

    Mileage : 94,000

    Default

    Just a bit of googling but does this help at all ?
    Generic OBD Error Code Details for P0093
    Fuel System Leak Detected - Large Leak

    check leak off pipes

    and read this
    http://www.fixya.com/cars/t12982100-p0513_p0087_p0093

  3. #3
    Regular Member
    Join Date
    Apr 2012
    Location
    mk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks for taking the time though not sure if this is the a way forward. I am sure members hers will have experienced this before.

  4. #4
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    61 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Surely by it thinking it has a fuel leak its easy enough to do a full hand and eye check of engine bay an fuel lines

    then look at rail pressures etc

    i wouldn't have thought be that hard to diagnose.

    i imagin they would require car for full day should anything need to be removed etc

    maybe try somewhere other than dealer

  5. #5
    Regular Member
    Join Date
    Apr 2012
    Location
    mk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Thanks. The report sheet states: Tech test fault p0093 rail pressure range,
    performance
    need to program BCM & recheck
    Last edited by david12; 27th April 2013 at 02:51.

  6. #6
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    P0093 is as easy as it gets on this *insert swaring words here* of an engine. Most likely fuel pump related. Mine has just started doing this again after 20k of peace. I'll have to check the fault codes tomorrow but this time it's losing power a bit differently...

  7. #7
    Regular Member
    Join Date
    Apr 2012
    Location
    mk
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Let me know how you get on please

  8. #8
    Regular Member
    Join Date
    Apr 2011
    Location
    Northamptonshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I've had a P0093 that I cleared and didn't return after I replaced the fuel filter, I had a fair bit of air in there so it hadn't been sealing well.

  9. #9
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Quote Originally Posted by iani View Post
    I've had a P0093 that I cleared and didn't return after I replaced the fuel filter, I had a fair bit of air in there so it hadn't been sealing well.
    How long ago was that? 6, 8 months? 10k, 20k miles? I don't think I can completly trust this engine even if it runs perfect with no fault codes.

  10. #10
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    Ok tried the code reader but it didn't work. The engine runs but not as it should obviously...one moment I'll be accelerating with full power up to 140+ the next it won't have enouh juice to pass 3000rpm...

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. p1792-71 gearbox fault code plus alarm sensor fault codes
    By stu f in forum Vectra C / Signum Car Chat
    Replies: 5
    Last Post: 13th August 2013, 21:05
  2. Replies: 15
    Last Post: 9th July 2011, 22:19
  3. Dealer fixed a fault now it's back!!
    By Si-SRI in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 16th January 2010, 13:47
  4. When a car goes to the dealer to have fault codes checked, does it.....
    By RSV_Ecosse in forum Vectra C / Signum Car Chat
    Replies: 7
    Last Post: 25th September 2007, 20:44
  5. £50+ at Leeds Dealers to Diagnose my Fault??!!
    By H3MSY in forum Vectra C / Signum Car Chat
    Replies: 18
    Last Post: 15th November 2006, 09:25

Visitors found this page by searching for:

dealer cannot replicate fault

vectra engine code 00093

vectra c eeror code 30000

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •