User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Signum 3.0cdti Auto problem

  1. #1
    Regular Member
    Join Date
    Apr 2013
    Location
    Llanelli
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Elite

    Engine : 3.0 cdti

    Year : 04

    Default Signum 3.0cdti Auto problem

    Hi I've just driven a signum 3.0cdti auto and it pulls like a train the only problem I think it's got is that when I easy of on the throttle the cars revs just drop to idle is this normal.

  2. #2
    North West - Assistant RO Woody's Avatar
    Join Date
    May 2012
    Location
    North West (Warrington)
    Post Thanks / Like
    Mentioned
    234 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C 3.2 Elite Estate Auto Facelifted

    Trim : Elite with loads of "Extras"

    Engine : 3.2 Z32SE

    Year : 2004

    Mileage : 94,000

    Default

    Hi fella, your revs will vary according to the gear that your auto gearbox is using and the speed you are driving at versus how much throttle you are giving it and the load on the car at the time.

    If you easy off on the throttle, you will likely find yourself in a higher gear than the one in use when you were "pulling like a train".

    Are there any warning lights on the dash, or spanner light even ? If so, just get the codes read by some helpful local member and post the details on here

  3. #3
    Regular Member
    Join Date
    Jan 2013
    Location
    Finland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by Markb73 View Post
    Hi I've just driven a signum 3.0cdti auto and it pulls like a train the only problem I think it's got is that when I easy of on the throttle the cars revs just drop to idle is this normal.
    If you don`t press throttle at all, revs drop to idle level and it`s normal on automatic cars. Someone correct me if I`m wrong

  4. #4
    Regular Member Celes's Avatar
    Join Date
    Sep 2007
    Location
    Slovenia, Koper
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Opel Signum

    Trim : Sport

    Engine : 3.0 CDTI

    Year : 12/03

    Default

    It's normal.

  5. #5
    Regular Member
    Join Date
    Apr 2013
    Location
    Llanelli
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Elite

    Engine : 3.0 cdti

    Year : 04

    Default

    No warning lights on dash, but I noticed that above 50mph it holds it's revs and doesnt drop to tick over.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Does my 3.0cdti Auto have a DPF?
    By renodci in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 4th February 2021, 11:51
  2. 2004 3.0cdti signum auto
    By scou5er in forum Y & Z30DT Specific
    Replies: 4
    Last Post: 19th January 2013, 18:19
  3. '03 Signum V6 auto transmission problem
    By Arnie in forum Engine & Drivetrain
    Replies: 2
    Last Post: 8th June 2009, 20:00
  4. Vectra 3.0CDTi Auto
    By Celes in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 5th May 2009, 21:57
  5. 3.0cdti sri estate auto
    By Adamdavi3s in forum Cars for sale
    Replies: 4
    Last Post: 5th March 2009, 22:19

Visitors found this page by searching for:

vectra c 3.2 v6 automatic transmission slipping or holding revs

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •