User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Aftermarket radio installation help

  1. #1
    Regular Member cardiffgareth's Avatar
    Join Date
    Mar 2013
    Location
    Vale of Glamorgan
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C 1.9 CDTi 120bhp 8v

    Trim : Life

    Engine : 1.9 CDTi

    Year : 2005

    Default Aftermarket radio installation help

    So! My Dynamic Sounds fascia adaptor / wiring kit off eBay turned up yesterday but missing the aerial adaptor so after a quick email it turned up today! Blinking fast!

    Started installing the wiring onto the back of the radio and all was going well, the plugs all went together albeit it rather scary looking as there are so many wires to now try and squash into the back of the dash as I already have a piggyback Parrot loom plugged into the car radio loom:



    so off I went to the car. Removed the old CD30 radio and plugged in the multiplug and the aerial and my radio came to life so 'so far' it was going well!

    BUT!

    the steering wheel controls are not working? I unplugged the Parrot loom and plugged the new interface loom directly into the VX loom but that didn't make a difference so that ruled out an issue with the Parrot piggyback loom causing problems. This is a picture of the stalk interface showing it all plugged in. It only can go in on way and also each side has a different type of connector so it can't be plugged in incorrectly:



    and here it is going into to the back of the head unit:
    Note there is only one place it can go and the connection is good and tight.



    According to the manual for my radio, where the stalk adaptor is currently plugged into is correct:



    So, it's plugged into the 'Remote Control' and 'RC-GND' plugs on the rear of the radio so I can't see why they don't work ??

    Any ideas ???

    Also the old VX cage. Does it have to come out as my god its in there! I've released the 2 catches at the base of the cage but there are another 3 at the top that I can't get leverage on as I'll snap the plastic that the cage is in. I don't know if there are any more catches that are hidden? I've unscrewed the torque screw at the rear of the cage via a screwdriver that I managed to improvise with!

    This is the kit I bought:
    http://www.ebay.co.uk/itm/2511020407...84.m1439.l2649

  2. #2
    Regular Member Mark-R's Avatar
    Join Date
    Mar 2012
    Location
    Dundee
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : GSI

    Trim : (vxr/irmy)

    Engine : 3.2 v6

    Year : 2004

    Default

    I dont know anything about the wiring but my cage had a screw at the back of it.

  3. #3
    Regular Member cardiffgareth's Avatar
    Join Date
    Mar 2013
    Location
    Vale of Glamorgan
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C 1.9 CDTi 120bhp 8v

    Trim : Life

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Quote Originally Posted by Mark-R View Post
    I dont know anything about the wiring but my cage had a screw at the back of it.
    Cheers Mark, yep got that one out but its still in the solid and I mean rock solid!!

  4. #4
    Regular Member Mark-R's Avatar
    Join Date
    Mar 2012
    Location
    Dundee
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : GSI

    Trim : (vxr/irmy)

    Engine : 3.2 v6

    Year : 2004

    Default

    Yeah mine was stuck in too i bent it in the middle a little same with the sides and put my hands in and yanked it but watch you're hands as its sharp.

  5. #5
    Regular Member paz_badboy4life's Avatar
    Join Date
    Dec 2009
    Location
    Leicestershire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi Dual Fuel NAV

    Trim : PreFace SRi

    Engine : 1.8 LPG

    Year : 53

    Default

    my steering wheel adapter only started working once everything was all connected up, including the info screen on the dash. hth.

  6. #6
    North West - Assistant RO Woody's Avatar
    Join Date
    May 2012
    Location
    North West (Warrington)
    Post Thanks / Like
    Mentioned
    234 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C 3.2 Elite Estate Auto Facelifted

    Trim : Elite with loads of "Extras"

    Engine : 3.2 Z32SE

    Year : 2004

    Mileage : 94,000

    Default

    The cage needs to be semi collapsed before it will come out. Take the base section, hold onto the centre and lift upwards, so that the bottom flat piece bends with a centre "V" pointing upwards and takes the strain out of the fitting and then try

  7. #7
    Regular Member cardiffgareth's Avatar
    Join Date
    Mar 2013
    Location
    Vale of Glamorgan
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C 1.9 CDTi 120bhp 8v

    Trim : Life

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Cheers all, I'll retackle the cage tomorrow morning. I've routed the radios rear iPhone jack socket lead and rear USB lead into the bottom cubby hole, just need to drill it and add a rubber grommet and that'll be their new home!

    I connected everything up on the radio first and then took it out to the car when I then connected up the big VX multi plug, the aerial and the stalk controls so in theory there was nothing else to connect but they were having none of it?

  8. #8
    Regular Member cardiffgareth's Avatar
    Join Date
    Mar 2013
    Location
    Vale of Glamorgan
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C 1.9 CDTi 120bhp 8v

    Trim : Life

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Do you think that black box could be faulty? Do I need it or could I just either solder or scotch lock the grey and the white cable to their matching ends ?

  9. #9
    Regular Member Mark-R's Avatar
    Join Date
    Mar 2012
    Location
    Dundee
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : GSI

    Trim : (vxr/irmy)

    Engine : 3.2 v6

    Year : 2004

    Default

    It's a bit late sure someone tomorrow will be here to help with it if you dont get it in the morning.

  10. #10
    Regular Member ThatAudioBloke's Avatar
    Join Date
    Feb 2013
    Location
    Newcastle, UK
    Post Thanks / Like
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : CDTI 150

    Year : 2006

    Mileage : 103000

    Default

    ETA - just re-read your post and noticed that you confirmed the radio is powering up, that rules out the black box being faulty as it is reading the CAN wakeup command.

    I'm assuming this is a Blaupunkt radio, going by that patch lead. Take a look at these instructions if so: http://www.nexxia.co.uk/PDF_Files/CTBLAUPUNKTLEAD.pdf

    It says about waking the radio up before connecting the stalk plug, then giving it 20 seconds before trying it out, might be worth a go. I remember from my fitting days that some of these stalk kits seemingly needed you to wait for specific planetary alignment, require chanting in Esperanto and the sacrifice of multiple virgins before they'd work correctly!!

    Regarding the cage, you need to get a bit medieval on it, unfortunately. Bend it at the split at the bottom and you should be able to get it to release, you can straighten it out when it's out though so it's not too much of a hassle.

    As for hiding all of the wiring, pull the glovebox out (again) and you can tuck the wiring over to the left hand side. The Vec is one of the easier cars to hide multiple looms on!
    Last edited by ThatAudioBloke; 21st April 2013 at 08:58.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. CD70 sat nav to aftermarket radio???
    By elite150 in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 6th April 2011, 19:30
  2. Aftermarket radio install
    By andyhu009 in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 21st August 2009, 14:55
  3. How to acces the BC with an aftermarket radio???/
    By new2theroad in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 16th July 2009, 01:40
  4. Aftermarket Radio
    By Bethan39 in forum Electrical & ICE (including SatNav)
    Replies: 5
    Last Post: 19th September 2008, 14:25
  5. Aftermarket SatNav installation
    By muffking in forum ICE Gallery
    Replies: 14
    Last Post: 5th September 2007, 20:36

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •