User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: 2.2 Direct engine trouble

  1. #1
    Regular Member
    Join Date
    May 2012
    Location
    Wiltshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRi Vx Line Nav

    Engine : 2.0 Cdti

    Year : 2011

    Mileage : 19500

    Question 2.2 Direct engine trouble

    Hi guys,

    On a trip to Gillingham (Dorset) today from Salisbury I had pulled up and been out of the car (2006 plate vectra 2.2 direct SRi, which was running fine) for about half an hour. When I jumped back in and started it up it started fine. Pulled away and the damn thing nearly stalled and the 'limp home' light came on. Not wanting to 'limp home' at 25 miles an hour nearly 50 miles I pulled over and killed the engine. Popped the bonnet and could see nothing untoward and it started up again fine, no 'limp home'

    However, now when driving the car wont rev above 4000, in any gear, or even in neutral. Revs a little slower to about 3000 then suddenly its like driving through treacle until about 3500 then fine again until 4000. It is like hitting an electronic limiter but no lights on the dash. I have no TC or anything like that.

    Any ideas as to what it might be? I have had the cam chain replaced about 8 months ago, no engine damage and has been fine since then. Any other info required please let me know. Thanks!

  2. #2
    Ex Vec-C Admin Ian-Highlander's Avatar
    Join Date
    Jun 2008
    Location
    Ely, Cambridgeshire
    Post Thanks / Like
    Mentioned
    62 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia Tourer

    Trim : Elite

    Engine : 2.0 CDTI (160ps)

    Year : 2010

    Default

    Most likely to be the high pressure fuel pump or fuel pressure regulator, both are very very common (and regular) issues on the 2.2 Direct I'm afraid.
    "Doing a good job here is like wetting your pants in a dark suit, you get a warm feeling but nobody else notices"
    Maptun Tuned 2.0T Estate - click HERE for mods list.
    Brentwood 2012: Winner, Saturday Show. Hull 2012: Winner, Best Estate. Hull 2013: Winner, Best Estate & Runner Up, Best I.C.E

    Now Gone, bring on the Insignia (now "Teapot" Tuned)...

  3. #3
    Regular Member
    Join Date
    May 2012
    Location
    Wiltshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRi Vx Line Nav

    Engine : 2.0 Cdti

    Year : 2011

    Mileage : 19500

    Default

    Had a brand harry spankers HPFP just over a year ago. I wouldn't have bought it otherwise lol. Have been told that it could be something as simple as the MAF sensor but have no idea where it is to look / check it. Or what I am looking for to be honest. If it is the fuel pressure regulator how much will that be to put right?

  4. #4
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    get the fault code(s) read out.

    Beats guesswork any day of the week.

  5. #5
    Regular Member
    Join Date
    May 2012
    Location
    Wiltshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRi Vx Line Nav

    Engine : 2.0 Cdti

    Year : 2011

    Mileage : 19500

    Default

    Ill try and get it done tomorrow and post the diag report here. Hopefully will shed some light. I was kinda hoping it would be one of those "deffo your ***** mate, happened to mine" sort of things. I'm just not that lucky I guess. Lol.

  6. #6
    Regular Member Tadpole's Avatar
    Join Date
    Dec 2008
    Location
    'I haven’t lost my marbles, they’re in a bag somewhere? .. '
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hope you are using 'good' fuel as supermarket type is well known not to be recommended .......................

  7. #7
    Regular Member
    Join Date
    May 2012
    Location
    Wiltshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : SRi Vx Line Nav

    Engine : 2.0 Cdti

    Year : 2011

    Mileage : 19500

    Default

    We only have a Murco or a Coop garage near us and afaik Coop use BP for fuel.

    Anyway a friend of a friend of mine had my car today and did a code check on it. It came up with EGR / O2 / Fuel rail and misfire faults. He has written the codes down for these but I don't have them, chances are I never will as I may have called him lots of bad names when he told me that the car was now error code free as "it couldn't be all of them so I reset them all and then tried to get it to throw up the code it will have given you when the limp mode came on".

    This however didn't happen as try as he might the car, although still drives like it did (ie crap) but will not throw up any error or go into limp mode. A new development however is that it will rev higher if you let off the throttle and then just as the revs drop give it the beans again. And tends now to rev almost all the way in neutral.

    I don't fancy having to replace half my engine because some **** (who to be honest probably thought he was kind of helping) cleared all my fault codes. So if anyone has any help / advice / cheap parts / ideas / a small engine God / or something similar I am all ears.

    Fingers / toes and everything else crossed here!

  8. #8
    Regular Member Paulwr's Avatar
    Join Date
    Mar 2012
    Location
    Ormskirk, Lancs
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Astra H 1.8 VVT

    Trim : SRi XP 3dr

    Engine : Z18XER

    Year : 2009

    Mileage : 12k

    Default

    Sounds like the infamous HPFP or FPR.

    I used to have a Z22YH and have read loads of threads about this.

    These symptoms always seem to be linked to either one or both of these fuel system parts.

    Try asking on http://www.z22se.co.uk/forum/ these guys have loads of knowledge about the Z22SE and Z22YH engines.

    Hope you get it sorted.

  9. #9
    Regular Member
    Join Date
    Dec 2006
    Location
    Oxfordshire
    Post Thanks / Like
    Mentioned
    13 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Astra-J

    Trim : Elite

    Engine : 2.0 CDTi

    Year : 2013

    Default

    Quote Originally Posted by Tadpole View Post
    Hope you are using 'good' fuel as supermarket type is well known not to be recommended .......................
    I've owned my 2.2 direct for nearly 6 yrs now. Most of the time fed on supermarket fuel.

    If supermarket fuel was rubbish, then they wouldn't be allowed to sell it and there would be broken down cars the length and breath of the country.

    For all intense purposes it's the same stuff with one or two less additives in it. Basically the same spec as last years fuel of the branded ones.

  10. #10
    Regular Member chewy71's Avatar
    Join Date
    Sep 2010
    Location
    Lincolnshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    some light reading buddy: http://www.bbc.co.uk/blogs/watchdog/2009/01/12/

    I had a 2004 2.2i and had the fule pump replaced with 2 of the supposed re-design, both failed in the same manner. I've now run the 1.9CDTI 150 for 4 years - no problems at all.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. engine trouble
    By Sigchris in forum Engine & Drivetrain
    Replies: 1
    Last Post: 15th May 2012, 21:57
  2. Engine Trouble
    By Vizzeh in forum Engine & Drivetrain
    Replies: 21
    Last Post: 28th December 2010, 09:22
  3. Help: More engine trouble!
    By Marky in forum Engine & Drivetrain
    Replies: 4
    Last Post: 29th April 2010, 16:34
  4. 2.2 direct - trouble starting/running
    By Ant SRi in forum Engine & Drivetrain
    Replies: 35
    Last Post: 4th November 2008, 09:18
  5. Please help engine trouble!
    By regishaunus in forum Engine & Drivetrain
    Replies: 15
    Last Post: 8th November 2007, 12:48

Visitors found this page by searching for:

u2103-70 vectra c

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •