User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Mates poorly signum

  1. #1
    Regular Member veclee's Avatar
    Join Date
    Nov 2012
    Location
    skegness
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : club

    Engine : 1800

    Year : 05

    Mileage : 63000

    Default Mates poorly signum

    After some info for a mate the engine light has come on gone into limp mode wont rev above 3000 hes taken it to a kid he knows who seems to think high pressure fuel pump on the cam shaft? Ive asked for codes but im yet to hear of any its a 05 2.2 direct petrol prefface would any body have any ideas on this and i do keep asking for codes

  2. #2
    Regular Member Lordish's Avatar
    Join Date
    Feb 2012
    Location
    Luton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like the fuel pump to me. Not a cheap part though!

  3. #3
    Regular Member squirrell25's Avatar
    Join Date
    Jan 2010
    Location
    wednesbury
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SIGNUM 2.0T

    Trim : WAS DESIGN

    Engine : Z20NET

    Year : 2006

    Mileage : 99.000

    Default

    just got mine back from the dealer for the same problem

    i had mine done under the aa recovery repair cover total bill was £661 but the aa only cover £465 so i had to pay the rest but they also done the recall on the handbrake while it was there


    pumps are about £280 on the bay

  4. #4
    Regular Member Lordish's Avatar
    Join Date
    Feb 2012
    Location
    Luton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check to see what make the fuel pump is at the mo. seimans is the rubbish one that tends to fail. Continental one is the better fuel pumps.

  5. #5
    Regular Member
    Join Date
    Mar 2009
    Location
    morecambe
    Post Thanks / Like
    Mentioned
    54 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    thats wrong continwas supposed to be the revised one mine failed and went bak to a siemens one and it was fine i also think @chewy had tje same

  6. #6
    Regular Member Lordish's Avatar
    Join Date
    Feb 2012
    Location
    Luton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Really. I had the seimans and it was replaced with the continental. Oh we'll agree to disagree. Lol. I don't know then.

  7. #7
    Regular Member
    Join Date
    Mar 2009
    Location
    morecambe
    Post Thanks / Like
    Mentioned
    54 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2007

    Default

    no need to me i no these cars like the bak of my hand ues the conti was supposed to be revised but they fail aswell siemens lasted longer for me

  8. #8
    Regular Member Lordish's Avatar
    Join Date
    Feb 2012
    Location
    Luton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by paulvectrac View Post
    no need to me i no these cars like the bak of my hand ues the conti was supposed to be revised but they fail aswell siemens lasted longer for me
    Fair enough. My conti one has been bang on the money for me but I'm no expert.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. i have a poorly signum
    By squirrell25 in forum Engine & Drivetrain
    Replies: 12
    Last Post: 16th April 2013, 16:21
  2. A very dirty, poorly Signum
    By BigWilko in forum Quick Photo Album
    Replies: 2
    Last Post: 27th June 2011, 10:32
  3. Poorly 2.0T Signum
    By chill_za in forum Engine & Drivetrain
    Replies: 7
    Last Post: 31st May 2011, 14:50
  4. Is it poorly?....
    By bobby-tupper in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 15th December 2008, 14:22
  5. Poorly Signum
    By Maverick in forum Vectra C / Signum Car Chat
    Replies: 35
    Last Post: 17th October 2007, 17:39

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •