User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Unresponsive parrot MKI 9100?

  1. #1
    Regular Member Henry42's Avatar
    Join Date
    Jun 2011
    Location
    South Shields
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Unresponsive parrot MKI 9100?

    Morning all, i have had fitted a parrot mki9100 for about 9 months now with no issue, now all of a sudden its become completely unresponsive, dosent power up, wont turn on, no lights come up, Iphone wont pick it up.

    Was toying with the idea of going back to were i bought and had it fitted, but thought i would see first if anyone else has had this problem.

    Thanks in advance.

  2. #2
    Regular Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    VXR where are you now
    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Nissan GT-R R35 Vectra XP2 CDTI

    Trim : Nissan GT-R R35

    Engine : 3.8 twin turbo 700hp

    Year : 2010

    Default

    if its not powering up it sounds like a fuse has popped fella have you noticed anything else not working?

  3. #3
    North West - Assistant RO Woody's Avatar
    Join Date
    May 2012
    Location
    North West (Warrington)
    Post Thanks / Like
    Mentioned
    234 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C 3.2 Elite Estate Auto Facelifted

    Trim : Elite with loads of "Extras"

    Engine : 3.2 Z32SE

    Year : 2004

    Mileage : 94,000

    Default

    , also have you checked the battery in the Parrot remote ?

    EDIT - It's not the remote that isn't working
    Last edited by Woody; 17th April 2013 at 09:47.

  4. #4
    Regular Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    VXR where are you now
    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Nissan GT-R R35 Vectra XP2 CDTI

    Trim : Nissan GT-R R35

    Engine : 3.8 twin turbo 700hp

    Year : 2010

    Default

    he said its not powering up bud not that the remotes not working

  5. #5
    Regular Member ThatAudioBloke's Avatar
    Join Date
    Feb 2013
    Location
    Newcastle, UK
    Post Thanks / Like
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : CDTI 150

    Year : 2006

    Mileage : 103000

    Default

    If the radio still works but the parrot doesn't, it's either one of the barrel fuses on the parrot loom as suggested above, or these have been known to have intermittent connection issues between the screen and the screen dock. This would give the symptoms you have suggested as the kit won't boot up at all if the screen is not seated correctly.

    Easy to fix, take the screen off the mount, ensure the screen and mount connections are clean and fit them back together. Make sure the screen is completely pushed home and it should boot if that was the problem.

    Worst case scenario is that the blue box is knackered, but try the easy things before falling back to that. If it's only 9 months old, it'll still be well within its warranty period so failing the basic checks, take it back and get the installer to sort it for you.

  6. #6
    Regular Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    VXR where are you now
    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Nissan GT-R R35 Vectra XP2 CDTI

    Trim : Nissan GT-R R35

    Engine : 3.8 twin turbo 700hp

    Year : 2010

    Default

    Quote Originally Posted by BoostPuppy View Post
    If the radio still works but the parrot doesn't, it's either one of the barrel fuses on the parrot loom as suggested above, or these have been known to have intermittent connection issues between the screen and the screen dock. This would give the symptoms you have suggested as the kit won't boot up at all if the screen is not seated correctly.

    Easy to fix, take the screen off the mount, ensure the screen and mount connections are clean and fit them back together. Make sure the screen is completely pushed home and it should boot if that was the problem.

    Worst case scenario is that the blue box is knackered, but try the easy things before falling back to that. If it's only 9 months old, it'll still be well within its warranty period so failing the basic checks, take it back and get the installer to sort it for you.
    and trust me hes a man that knows everything about these things...

  7. #7
    Regular Member Henry42's Avatar
    Join Date
    Jun 2011
    Location
    South Shields
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by chrisvectra View Post
    if its not powering up it sounds like a fuse has popped fella have you noticed anything else not working?
    No everything else is working fine mate.

  8. #8
    Regular Member Henry42's Avatar
    Join Date
    Jun 2011
    Location
    South Shields
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by BoostPuppy View Post
    If the radio still works but the parrot doesn't, it's either one of the barrel fuses on the parrot loom as suggested above, or these have been known to have intermittent connection issues between the screen and the screen dock. This would give the symptoms you have suggested as the kit won't boot up at all if the screen is not seated correctly.

    Easy to fix, take the screen off the mount, ensure the screen and mount connections are clean and fit them back together. Make sure the screen is completely pushed home and it should boot if that was the problem.

    Worst case scenario is that the blue box is knackered, but try the easy things before falling back to that. If it's only 9 months old, it'll still be well within its warranty period so failing the basic checks, take it back and get the installer to sort it for you.
    Quality, thank you very much for the advice, will give it a go tonight!

  9. #9
    Regular Member Henry42's Avatar
    Join Date
    Jun 2011
    Location
    South Shields
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    BUMP!!!

    Afternoon Fellas! still having the same issue, anyone know the Fuse number for the parrot itself?

  10. #10
    Regular Member rich r's Avatar
    Join Date
    Feb 2011
    Location
    Selby
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The Parrot has it's own fuses, in the loom. It takes it's power from the normal radio feed (through the ISO connectors). So if the radio's working but the Parrot isn't, then it's likely to be one of these fuses rather than one of the Vectra's fuses.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine feels Dull and Unresponsive
    By thompo5 in forum Engine & Drivetrain
    Replies: 26
    Last Post: 9th January 2011, 14:01
  2. Parrot Mki 9100 arriving 2mara, got last few questions
    By ishaqmir in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 20th May 2009, 22:32
  3. Parrot HELP!!!!!!!!!!!!!!!!!!!
    By Jamie in forum Electrical & ICE (including SatNav)
    Replies: 28
    Last Post: 31st March 2007, 15:18
  4. Car installation for QTEK 9100?
    By G.O'Rilla in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 19th March 2007, 19:01

Visitors found this page by searching for:

parrot mki9100 screen not working

parrot mki9100 not working

parrot mki9100 not turning on

parrot mki9100 problems

parrot mki9100 wont power onParrot mki9100 reboot loopparrot mki9100 stopped workingparrot mki9100 no displayparrot 9100 screen not workingparrot mki9100 does not turn onparrot 9100 throublesparrot mki9100 bluetooth not workingparrot bluetooth mki9100 wont power onparrot mki9100 no powerparrot mki 9100 fuseparrot mki9100 display not workingparrot mki9100

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •