User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Judder at 1500rpm 120bhp 2007

  1. #1
    Regular Member VectraCyorks's Avatar
    Join Date
    Dec 2011
    Location
    staxton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra C

    Trim : Exclusiv


    Year : 2007

    Default Judder at 1500rpm 120bhp 2007

    Hi

    I Have a fault with my 2007 120bhp cdti, it judders at smack bang on 1500rpm no higher no lower slap bang on 1500revvs, it only does it intermittently, i have scoured the threads but i havent found a 120bhp with the same issue, things i have replaced are the MAF, EGR and the boost pipes (near slam panel) cleaned the MAP and cleaned my throttle body out, could anyone shed any light on this? any help would be fantastic

    Dave

  2. #2
    Regular Member
    Join Date
    Jan 2012
    Location
    Gloucestershire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    1500rpm is about where the turbo kicks in, so maybe the boost control solenoid? This is the small unit that the vacuum hoses attach to on your slam panel.

  3. #3
    Regular Member VectraCyorks's Avatar
    Join Date
    Dec 2011
    Location
    staxton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra C

    Trim : Exclusiv


    Year : 2007

    Default

    Hi Thanks for your reply, i have also changed that too... im at a dead end now would it be anything to do with the fuel pressure sensor just to the left of the MAP?

  4. #4
    Regular Member
    Join Date
    Jan 2012
    Location
    Gloucestershire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Not sure about the fuel pressure sensor, but wouldn't have thought that this would only cause a problem at 1500rpm. I know this sounds really basic, but have you tried just unplugging the EGR? My Vectra currently has a problem with the EGR, even though it is new; if plugged in, I get juddering etc, as I did with the one beforehand, but unplugged there is no problem - so probably an electrical loom/connection problem. Since mapped out - no problem!

  5. #5
    Regular Member VectraCyorks's Avatar
    Join Date
    Dec 2011
    Location
    staxton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra C

    Trim : Exclusiv


    Year : 2007

    Default

    ah now thats intersting! i will give that a go, sorry to be a little green on this but will this affect my power or upset the computer? the only other thing i can think of is number three injector but if i remember rightly, my engine does not need this wiring upgrade? thanks again for your help. Just as a side note i had the car remapped and it hasnt made any difference to the judder.

  6. #6
    Regular Member
    Join Date
    Jan 2012
    Location
    Gloucestershire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    You will get the spanner light, followed by the engine/emissions light after a restart or two, but this will not affect performance. I have two 1.9cdtis (god knows why) and both have the EGRs unplugged - one is mapped out and hence doesn't show the emissions light but the other I plug back in before the MOT.

  7. #7
    Regular Member
    Join Date
    Jan 2012
    Location
    Gloucestershire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    No. 3 injector is as you say a renowned problem on the 150ps and not so much, if at all, the 120.

  8. #8
    Regular Member VectraCyorks's Avatar
    Join Date
    Dec 2011
    Location
    staxton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra C

    Trim : Exclusiv


    Year : 2007

    Default

    yeah i got the impression it wasnt on the 120's much, cracking il give that a go! thanks for your help!!! i wonder if a blanking restriction plate may fix this? or would this be another learning curve?

  9. #9
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800 non vvt

    Year : 2004

    Mileage : 167340

  10. #10
    Regular Member VectraCyorks's Avatar
    Join Date
    Dec 2011
    Location
    staxton
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra C

    Trim : Exclusiv


    Year : 2007

    Default

    Hi all well ive had the filter out of the boost valve and there has been no difference in performance or judder, it wasn't dirty either but it was worth a try, ive had the EGR unplugged and if im honest I think its worse?!?! so im going to try a new MAP sensor at the weekend and see if I get anywhere, does anyone know how these sensors actually work? are the two prongs inside stationary or are they supposed to move?

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Engine Judder at 1500 rpm 2007 120bhp
    By VectraCyorks in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 16th April 2013, 22:11
  2. 3.0CDTI V6 1500rpm engine judder - Facelift??
    By doncaster_mainline in forum Engine & Drivetrain
    Replies: 50
    Last Post: 11th August 2012, 15:25
  3. 120bhp 2007 Vectra c
    By jonny_adams60 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 18th January 2012, 13:23
  4. No Power below 1500rpm
    By stuart813 in forum Engine & Drivetrain
    Replies: 14
    Last Post: 29th July 2010, 21:18

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •