User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Here is a conundrum (power steering, ABS & TC)

  1. #1
    Regular Member
    Join Date
    Mar 2009
    Location
    sheffield
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Here is a conundrum (power steering, ABS & TC)

    I was wondering if anyone has experienced the problems i'm having at the moment or if anyone knows what my issue might be.

    For a while every so often and with no particular reason the ABS and TC lights come on on my dash (the ABS and TC definitely don't work when the lights are on) Like I said it would happen for a couple of days then be fine again for a week maybe a month. I thought this was a faulty hub sensor but it was never on when the car was in for other things so never got it checked out.

    Anyway, in the past couple of weeks as I've set off driving after about 30 seconds to a minute I can feel the car stuttering as if it's loosing power then the ABS & TC lights come on and it's fine. This has been every time I've been in it not just intermittently as it was before.

    Then I could feel the steering was a little odd. It felt like the power steering wasn't coming on straight away and there was like a half a second delay until it kicked in when turning.

    Then I've come to drive it today and the power steering is gone completely. There was a strong smell like something has burnt out in the cabin. At first i thought it would be the steering pump but then I've thought it's Probably connected to the ABS & TC fault as the lights haven't been on since.

    Any ideas anyone?

  2. #2
    Regular Member
    Join Date
    Nov 2012
    Location
    trowbridge wiltshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Gsi

    Engine : 3.2 v6

    Year : 2003

    Mileage : 160k

    Default

    if your car started loosong power ( alternator on the blink ) some cars start shutting down unimportant systems . my veccy started playing up the other week , kept packing up as if it was out of fuel and all the abs , tc lights would come on and car would run like a bag of nails. at one point i was thinking fuel pressure sensor as it stank of eggs due to unburnt fuel in the cats, then we started thinking alternator as certain systems had packed up but in the end it turned out my air filter had collapsed and gone up into the air flow sensor, put another air filter on and she was fine and has been ever since.

    check your alternator is kicking out the right numbers
    maybe worth doing the brake pedal thingy , ignition off hold down both throttle and brake then put ignition on so the lights on the dash come on and count how many times the eml light flashes - - - - ( 10 flashes = 0 ) then search google for vauxhall fault codes or post em here . im pretty sure airflow sensor doesnt come up via this trick though

  3. #3
    Regular Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    VXR where are you now
    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Nissan GT-R R35 Vectra XP2 CDTI

    Trim : Nissan GT-R R35

    Engine : 3.8 twin turbo 700hp

    Year : 2010

    Default

    its probably your altenator thats gone bud but you dont say what model, year, spec, your car is? and your probably best to get the codes read of the ecu

  4. #4
    Regular Member
    Join Date
    Mar 2009
    Location
    sheffield
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sorry its a 1.9 cdti 120. I hope it's not the alternator I had a new one fitted whilst I've had the car (although i've probably done about 40K since then) and I remember it being ****** expensive.

  5. #5
    Regular Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    VXR where are you now
    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Nissan GT-R R35 Vectra XP2 CDTI

    Trim : Nissan GT-R R35

    Engine : 3.8 twin turbo 700hp

    Year : 2010

    Default

    what year and spec bud?? and have you checked the power steering fluid level? and does the car still start

  6. #6
    Regular Member alcutler's Avatar
    Join Date
    Nov 2010
    Location
    East Midlands
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c 1.9cdti 120 estate

    Trim : design



    Default

    Sounds very much like alternator as said above - but check the earthing between the chassis and the engine first.

  7. #7
    Regular Member
    Join Date
    Mar 2009
    Location
    sheffield
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by chrisvectra View Post
    what year and spec bud?? and have you checked the power steering fluid level? and does the car still start
    05 sxi 1.9 cdti 120, Not checked the steering fluid yet but I have checked the fuse. Is there an easy way to check the fluid? looks quite difficult to get to without removing stuff. It would help if the bottle was see-through instead of white plastic.

    The car is still drivable and everything else is working, radio fan lights etc.

  8. #8
    Regular Member
    Join Date
    Mar 2009
    Location
    sheffield
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by tbirdbooboo View Post
    if your car started loosong power ( alternator on the blink ) some cars start shutting down unimportant systems . my veccy started playing up the other week , kept packing up as if it was out of fuel and all the abs , tc lights would come on and car would run like a bag of nails. at one point i was thinking fuel pressure sensor as it stank of eggs due to unburnt fuel in the cats, then we started thinking alternator as certain systems had packed up but in the end it turned out my air filter had collapsed and gone up into the air flow sensor, put another air filter on and she was fine and has been ever since.

    check your alternator is kicking out the right numbers
    maybe worth doing the brake pedal thingy , ignition off hold down both throttle and brake then put ignition on so the lights on the dash come on and count how many times the eml light flashes - - - - ( 10 flashes = 0 ) then search google for vauxhall fault codes or post em here . im pretty sure airflow sensor doesnt come up via this trick though
    Tried the pedal thing but it didn't work. Would there be a fault code if there are no lights on my dash?

  9. #9
    Regular Member
    Join Date
    Mar 2009
    Location
    sheffield
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Any ideas?

  10. #10
    Regular Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    VXR where are you now
    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Nissan GT-R R35 Vectra XP2 CDTI

    Trim : Nissan GT-R R35

    Engine : 3.8 twin turbo 700hp

    Year : 2010

    Default

    have you got a multimeter? if you have then test what volts are on the battery and do it again with the engine running... also you could try cleaning the abs connector with some electrical cleaner and have you checked all the fuses under the bonnet and inside the car

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. Power steering pump noise? but no steering problems
    By bennettboy in forum Engine & Drivetrain
    Replies: 2
    Last Post: 2nd November 2012, 21:33
  3. Steering wheel light & loss of power steering
    By the_wave_rider in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 3rd August 2012, 14:09
  4. Steering wheel warning light , no power steering!
    By Domchapp in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 23rd July 2012, 22:11
  5. Possible New Job....Conundrum Please help.
    By Brocks in forum General Chat
    Replies: 23
    Last Post: 12th January 2007, 22:16

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •