User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: 1.8 ecotech rev problems 2003

  1. #1
    Regular Member
    Join Date
    Jul 2012
    Location
    west yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 1.8 ecotech rev problems 2003

    I wonder if you can help me please.


    Car went into limp mode few weeks ago, got it on a machine and it showed a misfire on one and three, so I assumed it was the coil pack.


    this morning I replaced the coil pack, that cleared the misfire fault but it was still in limp mode.


    It ticked over ok but the erg valve was hissing making me think there was some problem with the front cat.


    I Took off the sensor on top of the front cat, lambda i think its called and got full revs again, So do i need a new cat or should I replace the sensor.


    Both are costly how do I know which is the right choice?


    Thanks in advance.

  2. #2
    Regular Member Das's Avatar
    Join Date
    Jun 2010
    Location
    Yer Maws Bedroom
    Post Thanks / Like
    Mentioned
    40 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Honda Civic

    Trim : ES with Honda Image and City Packs

    Engine : 1.8 iVtec

    Year : 2009

    Mileage : 85000

    Default

    Its very common for the manicat to become blocked, or collapse, on older higher mileage 1.8's. Stick the sensor back in, get someone to start it and rev it whilst you stand at the rear and see if their is a decent amount of exhaust gases coming out the rear. If not them most likely the cat i goosed.

  3. #3
    Regular Member
    Join Date
    Jul 2012
    Location
    west yorkshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Anybody know good cats for cheap thanks in advance?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Signum 2003 2.2 dti problems
    By raf_gsx in forum Electrical & ICE (including SatNav)
    Replies: 1
    Last Post: 20th April 2019, 11:21
  2. 2003 1.8 idle and emission problems
    By omegapete in forum Engine & Drivetrain
    Replies: 2
    Last Post: 7th November 2012, 21:50
  3. Problems with a Vectra C 1.8 2003
    By awilson1234 in forum Engine & Drivetrain
    Replies: 71
    Last Post: 3rd August 2012, 10:58
  4. My Vectra C 2003 DTI cold starting problems solved hopefully
    By jameso in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 29th January 2011, 15:18
  5. Vecta 1.8 ecotech stalling / idle problems
    By baznap in forum Vectra C / Signum Troubleshooting
    Replies: 11
    Last Post: 5th February 2008, 08:35

Visitors found this page by searching for:

vectra c 1.8 rev prob

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •