User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 6 of 6

Thread: Heater plug change???

  1. #1
    Regular Member
    Join Date
    Nov 2010
    Location
    Bridgwater
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra 1.9 CDTI 120



    Year : 2004

    Mileage : 157,000

    Angry Heater plug change???

    Hey guys i have a 1.9 CDTI veccy and she has always presented a problem when starting! had her 3 years now and passes MOT every time but this starting nonsense is starting to drive me crazy!
    I have been advised by my very loyal mechanic to change the heater plugs which i will be doing this afternoon. I was working yesterday and she was very very hard to start and as i am a carer i am always stop starting, after my 3rd call she had enough and i killed the battery and had to have her jump started
    She drives like a dream no problems at all its just starting her.
    A new battery was put in last year and i have to yearly have the alternator re-brushed (if thats the right word :s).
    Any ideas anyone??
    cheers
    krissy

  2. #2
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    You can find various videos on YouTube about testing glowplugs and if you have a multimeter to hand you can also get an idea of the plugs' condition by measuring their resistances (that's all they are... a dirty great big resistor).
    Assuming the plugs themselves are ok, then you're looking at the relay that switches them on - relays do fail and are relatively cheap and easy to replace.
    After that you move to things like temperature sensors - if the computer thinks the engine is always hot it'll never switch on the glowplugs and vice versa.

    But for me, step one would be - is the glowplug light coming on for a few secs then going out before you turn over the engine? If not, why not?

    Then the relay, then the plugs themselves.

  3. #3
    Regular Member
    Join Date
    Nov 2010
    Location
    Bridgwater
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra 1.9 CDTI 120



    Year : 2004

    Mileage : 157,000

    Default

    Hey thanks yes the light comes on and off like normal i have the plugs so will change them as need car for work but will look at changing the relay if that fails.
    krissy

  4. #4
    Regular Member
    Join Date
    Nov 2010
    Location
    Bridgwater
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra 1.9 CDTI 120



    Year : 2004

    Mileage : 157,000

    Default

    Well i am now going to throttle my husbnd as my brother in law came round and noticed that the sensor fo the air filter was off so he put it back on and she starts every time, im gonna try her tomorrow and see what shes like
    thanks

  5. #5
    Regular Member Handyandy-UK's Avatar
    Join Date
    Mar 2009
    Location
    Suffolk, Englandshire
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : BMW 525i

    Trim : SE Touring

    Engine : 3.0

    Year : 2007

    Default

    Fingers crossed it does the trick for you. Although if the MAF was disconnected I would've expected a fault light on the dash and quite possibly rough running too.

  6. #6
    Regular Member
    Join Date
    Nov 2010
    Location
    Bridgwater
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra 1.9 CDTI 120



    Year : 2004

    Mileage : 157,000

    Default

    Yea scrap that today no change we have found that taking the coolant sensor off starts it so gonna get a new one but car has light come on so need to see if she goes into limp mode :s

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. heater plug circuit fault
    By ddlovetts in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 10th May 2012, 20:47
  2. P0380 Stored Glow Plug/Heater Circuit A Malfunction
    By frag45 in forum Engine & Drivetrain
    Replies: 1
    Last Post: 5th January 2011, 13:01
  3. plug change?
    By CLOMP in forum Vectra C / Signum Car Chat
    Replies: 2
    Last Post: 31st October 2009, 17:25
  4. 3.2 Spark Plug Change Help
    By 3.2_V6_VXR in forum Vectra C / Signum Car Chat
    Replies: 17
    Last Post: 11th May 2007, 14:29

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •