User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Engine hesitant if driven hard, fuelling?

  1. #1
    Regular Member
    Join Date
    Sep 2011
    Location
    Surrey
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Engine hesitant if driven hard, fuelling?

    Basically as title says, if I accelerate hard high up into the rev range I find the power drops and I get this hesitancy through some of the remaining gears, I can only think it's a fuelling issue so maybe a new fuel filter will cure it???? I really don't know so if someone has an idea I'm all ears, thanks.

  2. #2
    Regular Member stevoxsi's Avatar
    Join Date
    Sep 2012
    Location
    Coleraine, Norn Iron.
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Sri Vx-line

    Engine : 2.0 Cdti 160

    Year : 2011

    Default

    Have you done the airbox mod? I'm conviced it helped mine.

  3. #3
    Regular Member
    Join Date
    Sep 2011
    Location
    Surrey
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Would you care to explain as I'm not too sure what this is, is this removing what looks like a blanking piece of plastic in the airbox it's self or something else?

  4. #4
    Regular Member stevoxsi's Avatar
    Join Date
    Sep 2012
    Location
    Coleraine, Norn Iron.
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Sri Vx-line

    Engine : 2.0 Cdti 160

    Year : 2011

    Default

    There's a funnel shaped bit of plastic on the bottom of the box which clips out. Seems to cause only half the filter to get used. Should be a how2 on it.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Ticking 2.8 v6 auto and loss of power when driven hard
    By chunkey_monkee in forum Engine & Drivetrain
    Replies: 1
    Last Post: 13th February 2013, 23:25
  2. Struggling to start after re-fuelling
    By Bloicy 3.2 V6 GSI in forum Vectra C / Signum Troubleshooting
    Replies: 3
    Last Post: 1st August 2011, 18:50
  3. Engine is 'hesitant'
    By bighammerfan in forum Engine & Drivetrain
    Replies: 10
    Last Post: 30th September 2010, 09:34
  4. Hesitant 1.9cdti with engine light
    By DVectra55 in forum Engine & Drivetrain
    Replies: 5
    Last Post: 23rd March 2010, 11:41
  5. V6 CDTi Judder/Under-fuelling at Idle
    By ukanalyst in forum Vectra C / Signum Troubleshooting
    Replies: 22
    Last Post: 20th May 2008, 22:42

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •