User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: still getting a crunch

  1. #1
    Regular Member chris1804's Avatar
    Join Date
    Oct 2009
    Location
    Sandwell
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Club

    Engine : Y20DTH

    Year : 2005

    Mileage : 79k

    Default still getting a crunch

    I'm starting to get peed off with this car. I've replaced radiator mounts, arb bushes and drop links and still getting a crunch. It don't crunch when I go slow and I mean crawling over speed humps. But if I go 10mph + I get it. I've noticed I'm still on GM shocks and I've done 62K. Im now thinking about changing the shocks,springs and strut mounts. And hope it goes away . Anybody else had this and changed there shocks and the noise went?

  2. #2
    Regular Member Ozyboyross's Avatar
    Join Date
    Oct 2012
    Location
    Sprowston, Norwich
    Post Thanks / Like
    Mentioned
    6 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRi XP

    Engine : 1.9 CDTi 150

    Year : 2006

    Mileage : 90k

    Default

    Quote Originally Posted by chris1804 View Post
    I'm starting to get peed off with this car. I've replaced radiator mounts, arb bushes and drop links and still getting a crunch. It don't crunch when I go slow and I mean crawling over speed humps. But if I go 10mph + I get it. I've noticed I'm still on GM shocks and I've done 62K. Im now thinking about changing the shocks,springs and strut mounts. And hope it goes away . Anybody else had this and changed there shocks and the noise went?
    Mine does the same thing it curiously it doesn't do it when my engine is warm....

  3. #3
    Regular Member chris1804's Avatar
    Join Date
    Oct 2009
    Location
    Sandwell
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : Club

    Engine : Y20DTH

    Year : 2005

    Mileage : 79k

    Default

    well i think ive sorted it, changed arb bushes for powerflex ones and its been spot on since ive changed them, just gutted i didnt buy them first before i brought new shocks, springs.top mounts and bearings lol

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. A little crunch
    By Imraldis in forum Engine & Drivetrain
    Replies: 1
    Last Post: 22nd October 2012, 16:10
  2. still getting a crunch
    By chris1804 in forum Suspension, Wheels & Brakes
    Replies: 6
    Last Post: 6th June 2012, 12:04
  3. crunch noise again
    By chris1804 in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 18th May 2010, 18:51
  4. Crunch.....How ****ed off am I!!!!!
    By Maverick in forum Vectra C / Signum Car Chat
    Replies: 14
    Last Post: 4th March 2008, 17:12
  5. Crunch!!
    By Maverick in forum Vectra C / Signum Car Chat
    Replies: 22
    Last Post: 29th December 2006, 23:39

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •