User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Slugish pug 307

  1. #1
    Regular Member veclee's Avatar
    Join Date
    Nov 2012
    Location
    skegness
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : club

    Engine : 1800

    Year : 05

    Mileage : 63000

    Default Slugish pug 307

    Any body own or owned a pug 307 1.6 petrol 51 plate with the same symptoms very sluggish to set off but will pick up once you get going its seems the same in every gear at low revs but once it's going it runs ok if sat at say 2500 revs and put your foot down its picks up ok but mainly when pulling out of a junction and floor it to get up to speed its boooaaaar till it gets above 2000 revs then your off I would like to add its the wife's car I'm not personally stupid enough own one my self the vectra is to nice and runs fine lol
    Thanks in advance for any info

  2. #2
    Regular Member stevoxsi's Avatar
    Join Date
    Sep 2012
    Location
    Coleraine, Norn Iron.
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia

    Trim : Sri Vx-line

    Engine : 2.0 Cdti 160

    Year : 2011

    Default

    O2 sensor before the cat possibly. If you can get codes I can help more!

  3. #3
    Regular Member veclee's Avatar
    Join Date
    Nov 2012
    Location
    skegness
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : club

    Engine : 1800

    Year : 05

    Mileage : 63000

    Default

    There's no eml lights on the dash on startup flashes anti pollution fault but when asked dealer monkey he said its a petrol don't worry it don't mean any thing

  4. #4
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    61 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Seen a lot of them with O2 sensor problems.

    they all flash that anti pollution fault too

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. slugish
    By marc vectra sri in forum Engine & Drivetrain
    Replies: 8
    Last Post: 12th October 2011, 16:09
  2. SRi 150 - Car Slugish.. Please Help
    By Imi in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 1st December 2008, 12:31

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •