User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: Thermostat problem ??

  1. #1
    Regular Member
    Join Date
    Oct 2012
    Location
    Perth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Thermostat problem ??

    Hi Guys,

    Just bought a 1.9 SRI cdti 150 got at great price with 75,000 on the clock.

    When driving home noticed a few problems that I am hoping someone can shed some light too.

    1st The blowers from 1 to 3 seem to all be the same speed basically all come out at speed 1. When I move to no 4 it blows as no 4 would.

    2nd The blowers only blow out luke warm air doesnt matter if I turn up or turn down still the same temp just warm ?

    3rd I drove from Dundee to Stirling around 45 miles and the car temp never budged off of 80 it drives perfect and has loads of power.

    Any ideas would be appreciated.

  2. #2
    Regular Member spikeyboi33's Avatar
    Join Date
    Jan 2013
    Location
    Ireland/Poland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Prefacelift.

    Trim : "Elite"

    Engine : 2.0dti

    Year : 2003

    Mileage : 130,000

    Default

    Sounds like a shot thermostat alright.. But the blowers not going from 1 - 3 sounds like a relay to me..

  3. #3
    Regular Member krazylegz's Avatar
    Join Date
    Dec 2009
    Location
    South Shields
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Blowers will more than likely be the blower resistor, caused by leaking water into the blower motor from the bulk head as the the drainage channel blocks.

    Temperature could be thermostat stuck open slightly

    Sent from my iPhone using my fingers n thumbs

  4. #4
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default



    Thermostat and blower motor resistor. Both relatively easy to fix

  5. #5
    VIP-Member
    Join Date
    Dec 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats



    Engine : Z18XER



Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Thermostat problem
    By bluevec in forum Engine & Drivetrain
    Replies: 10
    Last Post: 6th December 2012, 17:28
  2. problem when replacing thermostat
    By jonny22 in forum Vectra C / Signum Troubleshooting
    Replies: 12
    Last Post: 23rd October 2012, 09:28
  3. Thermostat problem? Not sure to be honest
    By Envy in forum Engine & Drivetrain
    Replies: 3
    Last Post: 23rd March 2012, 03:19
  4. major thermostat problem!
    By valvelift in forum Vectra C / Signum Car Chat
    Replies: 6
    Last Post: 10th March 2011, 22:50
  5. Thermostat housing bolts problem
    By TonyTangles in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 2nd March 2011, 22:13

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •