User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Wow - catastrophic failure - car dead , er help please!!

  1. #1
    Regular Member
    Join Date
    Apr 2012
    Location
    Ellesmere Port
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Eek Wow - catastrophic failure - car dead , er help please!!

    I'll start at the top and hopefully someone will have an answer for me.
    I have an 04 Vectra C - 1.9CDTI SXI (120) not a bad bus and owned it for a year. Put a new battery on before christmas and, other than tyres no real problems shes now done 119,000 miles. But..........on Saturday I drove 4 miles to town and noticed the battery warning light was on as I drove. Parked, did my business, got back in and drove home good as gold and no battery light. Drove Sunday no problem. No mileage yesterday or today until this evening I wanted to go a half mile to put some diesel in which I did. My intention was then to go and get some bread and milk but When I came out and went to start, the car reacted as if the battery was dead. Got a couple willing samaritans to push me from the forecourt and jump started the car with cables.
    Decided to give her a run to charge the battery but, after about 3 miles, my ABS and ESP lights came on then off, then the power steering failure light came on and I lost.....strangely my power steering. Managed to limp home with ABS, ESP and power steering lights on and no power steering. Switched off, then when I tried to start again - dead as a dodo - won't even turn over. Can anybody tell me whats wrong please?? Oh and I never got the chuffing bread and milk!!! Thanks for any help, as always, in advance.

  2. #2
    Regular Member david-bell's Avatar
    Join Date
    Sep 2005
    Location
    eastlothian scotland
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra vxr

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2008

    Mileage : 31000

    Default

    Sounds like an alternator maybe

  3. #3
    Regular Member
    Join Date
    Apr 2012
    Location
    Ellesmere Port
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi David
    Hmmm, I had a thought on that but, I've no charging warning other than those 4 miles saturday? I was of the mind that maybe the cold weather was to blame for that 'blip' as later that day and sunday was fine. Even today I had no charge warning, it just seems to have died?

  4. #4
    Regular Member lofty's Avatar
    Join Date
    Sep 2007
    Location
    @home
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate

    Trim : Elite

    Engine : 1.9 CDTi


    Default

    My alternator died just over a year ago... no warning or anything, the car just died. It does sound like the alternator to me as well.

  5. #5
    Regular Member chrisvectra's Avatar
    Join Date
    Jul 2008
    Location
    VXR where are you now
    Post Thanks / Like
    Mentioned
    16 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Nissan GT-R R35 Vectra XP2 CDTI

    Trim : Nissan GT-R R35

    Engine : 3.8 twin turbo 700hp

    Year : 2010

    Default

    defo alternator fella

  6. #6
    Regular Member
    Join Date
    Apr 2012
    Location
    Ellesmere Port
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Hi Lofty, thanks, but did you get the same ABS/Power steering fault display mate?

  7. #7
    Regular Member lofty's Avatar
    Join Date
    Sep 2007
    Location
    @home
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Estate

    Trim : Elite

    Engine : 1.9 CDTi


    Default

    Quote Originally Posted by malcycee View Post
    Hi Lofty, thanks, but did you get the same ABS/Power steering fault display mate?
    when it died I got just about every light on the dash showing up.

  8. #8
    Regular Member
    Join Date
    Feb 2009
    Location
    Carnoustie
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    what they said

  9. #9
    Regular Member justin32's Avatar
    Join Date
    Aug 2011
    Location
    Basingstoke
    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c SRI Facelift

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2006

    Default

    exactly what everybody else said...alternator.

    Mine went within about 25 mins of battery light comming on.The last thing to fail on my car was power steering just as i turned into my road and managed to coast into my parking space.All my warning lights came on 1 at a time including my power steering warning light even though it was was working.

    IIrc i read somewhere that the steering is the last thing to go so you at least have a change of turning the wheel.....Damn the wheel is hard to trun without power steering

  10. #10
    Regular Member DAVIDD88's Avatar
    Join Date
    Jan 2011
    Location
    scottish region
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    As Above

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Catastrophic Failure ? Suggestions Please
    By macdad in forum Vectra C / Signum Car Chat
    Replies: 19
    Last Post: 16th March 2011, 09:00
  2. Dead PC - HELP
    By Leemarksmith in forum General Chat
    Replies: 31
    Last Post: 1st January 2011, 23:52
  3. Ps is dead
    By mattv6diesel in forum Games Room
    Replies: 9
    Last Post: 29th December 2010, 21:19
  4. My Car Is Dead
    By Matty H in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 31st October 2010, 10:44
  5. ECC dead... why?
    By stevedee3 in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 25th November 2006, 12:30

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •