User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Kangaroo petrol and no power

  1. #1
    Regular Member L33AVN's Avatar
    Join Date
    Feb 2008
    Location
    West Lothian, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    confused Kangaroo petrol and no power

    Hi folks,

    i apologise if this has been asked already but i couldnt find anything when i searched.

    i am having a bit of bother with my 1.8 petrol z17xe vec, i start it up after sitting for a few hours or more start to drive and its as if it kangaroo'ing/no power as if somethings choking it, if i start it up and leave it for a couple of minutes until the revs come down to idling (it usually revs at about 10k/15k then goes down. sometimes even revs itself up and down in the first few minutes, few times ive thought it was going to cut out)i can then drive off with no kangaroo!

    To add to this when i finally get going if i put my foot down theres just no power like it used to have, and if im cruising along between 30k and 40k revs whatever speed it seems to hit a flat spot?! 😣

    Has anyone had this problem and got to the bottom of it?
    Ive read that it could be the EGR valve but some people say its made the car worse after cleaning it, ive heard spark plugs/coil pack, air filter...... Just dont know, any info would be great. Dont want to have to take it to a garage and find out its something we could have done ourselves.

  2. #2
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    When was your last service?

    whats current milage?

    for a start point I would clean throttle body

  3. #3
    Regular Member L33AVN's Avatar
    Join Date
    Feb 2008
    Location
    West Lothian, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It was serviced a few months ago. Its currently around 62k miles.

  4. #4
    Regular Member Neve'o's Avatar
    Join Date
    Jan 2011
    Location
    Norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRi 150 Hatch

    Trim : SRi

    Engine : Z19DTH

    Year : 2008

    Mileage : 69'000

    Default

    Start with the things you can do yourself, clean the TB and EGR, check the condition of the plugs etc, if this doesn't improve things the next step may be a garage.

    Are you getting any warning lights? Have you had any work done on the car recently?

  5. #5
    Regular Member L33AVN's Avatar
    Join Date
    Feb 2008
    Location
    West Lothian, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ill try cleaning those, i say i...what i mean is ill get my OH to and ill spectate and get the tools �� Nah no work done on it at all. No error codes or lights either.

  6. #6
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Your pictue is of a facelift Vecytra are you sure you doint have a VVT?

  7. #7
    Regular Member puppet's Avatar
    Join Date
    Feb 2010
    Location
    East Ayrshire
    Problems Posted
    0
    Problems Solved
    1
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    10 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia 1.8 SRi

    Trim : VX Line Red

    Engine : 1.8VVT

    Year : 2011

    Default

    Quote Originally Posted by Ben50n View Post
    Your pictue is of a facelift Vecytra are you sure you doint have a VVT?
    Was thinking the same myself.

  8. #8
    Regular Member L33AVN's Avatar
    Join Date
    Feb 2008
    Location
    West Lothian, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    That pic is of my vectra

  9. #9
    VIP-Member Caveman_nige's Avatar
    Join Date
    Jun 2009
    Location
    South Coast
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    8 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum & Insignia

    Trim : Elite

    Engine : POS derv

    Year : 2014

    Default

    what year is it?

    even if it is an XE not all had EGRs as they were not on the later engines..

  10. #10
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800 non vvt

    Year : 2004

    Mileage : 145000

    Default

    you should not have a egr valve on face lift what reg plate is it ?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Shells V-Power petrol
    By Mark-R in forum Vectra C / Signum Car Chat
    Replies: 33
    Last Post: 12th November 2012, 19:36
  2. 2.2 petrol - loss of power when cold
    By gokartin in forum Engine & Drivetrain
    Replies: 5
    Last Post: 10th September 2010, 18:24
  3. 1.8 petrol 16 valve power increase,s ?
    By clancruiser in forum Petrol Engine related
    Replies: 15
    Last Post: 13th March 2010, 18:20
  4. Poor MPG and rough on Shell V power petrol
    By simac in forum Engine & Drivetrain
    Replies: 2
    Last Post: 8th January 2007, 13:11
  5. v-power petrol
    By KC in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 4th September 2006, 17:42

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •