User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 28

Thread: Battery light comes on dash

  1. #1
    Regular Member SlowCoach's Avatar
    Join Date
    Jan 2012
    Location
    Houghton Le Spring
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI 150

    Trim : Smart and Bad!

    Engine : Z19DTH

    Year : 2008

    Mileage : 105000

    Default Battery light comes on dash

    Ok, this seems to be an ongoing issue. Tested wirings etc and dont see the issue,

    But this i noticed...

    At start up, using wipers, drive on, battery light dont show up, i noticed the wiper start to slow down until the battery light comes on, the wipers retain back the normal speed. I could feel the slight change of engine before light comes on.

    This have been ongoing for so long, thought i report new findings to see if anyone might have had same thing or an advice?? Hope u could help me out peeps

  2. #2
    On a Sabbatical
    Join Date
    Jul 2011
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats




    Year : 06

    Default

    Sounds like you have got alternator problems

  3. #3
    Regular Member vmb2722's Avatar
    Join Date
    May 2012
    Location
    Blackpool/St Mary's Bay
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    10 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Exclusiv

    Engine : 1.9 CDTi 150

    Year : 2007

    Default

    Is it all the time or intermittent? Have you checked the alternator belt for tightness? If you have a volt meter you can put it acoss the battery with the engine running and see what the output is, it should be around 14volts

  4. #4
    Regular Member SlowCoach's Avatar
    Join Date
    Jan 2012
    Location
    Houghton Le Spring
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI 150

    Trim : Smart and Bad!

    Engine : Z19DTH

    Year : 2008

    Mileage : 105000

    Default

    Altnerator is ok, the belt's nice and tight, the output is 14.1v which is good. The altnerater have been checked at auto electric shop, passed And checked syarter motor, broken inside so repaired and passed,

    The battery light comes on 2-5 minutes every time from starting car.

    The battery holds good charge.

  5. #5
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Does the battery light come on when using the steering? I would still suggest that the alternator has a low output and requires a "load" test or you have an earthing fault?

    Again get your battery load tested, it may be on its last legs, can still show 12.6v but not be able to provide the amps.

  6. #6
    Regular Member SlowCoach's Avatar
    Join Date
    Jan 2012
    Location
    Houghton Le Spring
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI 150

    Trim : Smart and Bad!

    Engine : Z19DTH

    Year : 2008

    Mileage : 105000

    Default

    Alright thanks, will have them checked, know the steering is spot on cos never had any issues, been a light drive unlike hatch . Most estates are lighter in steering anyways.

    Have done running tests to see any issues or faults while driving including voltage etc. not a single error, or voltage drop. It varies around 13.8 to 14.1 that the battery light comes on dash.

    Looked at one place, light up could also mean battery charging! Thats in ford manual!!!

  7. #7
    Regular Member Ben50n's Avatar
    Join Date
    Dec 2011
    Location
    Seaham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The steering as you know is electrically powered and takes a considerable chunk of amperage at low spees, hence people tend to have flashing headlights as the power steering demands all of the alternator power.

    Light comes on when battery is not charging, thats why it lights up when you just have the ignition switched on and the engine is not running. There is normally an extra wire that runs from the alternator up to the warning light, check that there isnt a break or a bad connection.

  8. #8
    Regular Member SlowCoach's Avatar
    Join Date
    Jan 2012
    Location
    Houghton Le Spring
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI 150

    Trim : Smart and Bad!

    Engine : Z19DTH

    Year : 2008

    Mileage : 105000

    Default

    Quote Originally Posted by Ben50n View Post
    There is normally an extra wire that runs from the alternator up to the warning light, check that there isnt a break or a bad connection.
    I could only see 2 wires connected to alternator. It is the type that u put in bolt then nut to secure on. Could not find 3rd wiring. Where would this be located? Could see there is 3rd wore on other vectras. No idea why i only got 2.

  9. #9
    Regular Member
    Join Date
    Feb 2008
    Location
    Scunthorpe
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : LS

    Engine : 2.0 DTi

    Year : 52

    Default

    I had a new alternater fitted on my wifes Alhambra. Sometimes on startup the voltage (has a voltmeter on dash) is only 12v until it is reved, then holds steady at 14ish. Battery light doesn't come on but it didn't when the old alternator packed in! Could yours be doing this?

  10. #10
    Regular Member Sway's Avatar
    Join Date
    Nov 2012
    Location
    Bedfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    I have the exact same problem as you, its very annoying. do you know what make alternator you have? and what power output?
    if you hold the settings button down for a few seconds until you hear a beep, it should say test mode, you can scroll through by pressing one of the buttons until it comes to the onboard volt meter. when your wipers dim down usually the voltage will dip down to around 11v then the battery light will come on and it will boost back up to 14.1

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 16th August 2012, 10:07
  2. Battery Light ON - 14.1 volts at battery
    By snapsnap in forum Electrical & ICE (including SatNav)
    Replies: 0
    Last Post: 6th December 2011, 13:55
  3. Alternator/Battery Dash Warning Light
    By cavester in forum Vectra C / Signum Troubleshooting
    Replies: 31
    Last Post: 1st June 2011, 08:24
  4. HELP....battery light on dash?
    By hovis007 in forum Electrical & ICE (including SatNav)
    Replies: 8
    Last Post: 20th May 2009, 22:27
  5. battery light and a demented dash, any suggestions?
    By TKD Colin in forum Vectra C / Signum Car Chat
    Replies: 12
    Last Post: 19th January 2009, 21:40

Visitors found this page by searching for:

vectra c battery light intermittent

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •