User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: Vectra c est CDTI150

  1. #1
    New Member
    Join Date
    Feb 2013
    Location
    buckley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra cdti 150 est

    Trim : design

    Engine : 1.9

    Year : 2006

    Default Vectra c est CDTI150

    No power under 2000 rpm.replaced: EGR,full service,regen on DPF,new MAP and MAF,injector number 3 repair,but still no or very little power under 2000rpm??? Anymore ideas?please

  2. #2
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri auto

    Engine : 1.9 cdti 150

    Year : 2008

    Mileage : 119k

    Default

    Have you checked and replaced the boost vacuum pipes at the front right of the engine?

  3. #3
    Regular Member
    Join Date
    Feb 2012
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SIGNUM 1.9 CDTI ELITE

    Trim : ALL OPTIONS ELITE

    Engine : 1.9 CDTI 150

    Year : 2005

    Mileage : 140,000

    Default

    remove and clean throttle body and whilst its off clean the recess it fit onto.

  4. #4
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Have you checked boost solenoid and pipe work?

  5. #5
    Regular Member nutron's Avatar
    Join Date
    Jul 2005
    Location
    South Central England
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    18 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall

    Trim : very

    Engine : Z19DTH

    Year : Nosey

    Default

    What they said is the most common cause next to EGR.
    After that maybe the O2 sensor, they cause a simular fault but usually give a fault code.

  6. #6
    New Member
    Join Date
    Feb 2013
    Location
    buckley
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra cdti 150 est

    Trim : design

    Engine : 1.9

    Year : 2006

    Default

    I've cleaned egr and throttle body and the manifold.vac tested pipes and pressure tested inter cooler and boost pipes.no faults stored,and everything is workin as is should on the live data on me scanner.ive fixed a couple of these problem on customers cars.but can't fix my own!!

  7. #7
    Regular Member
    Join Date
    Feb 2012
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SIGNUM 1.9 CDTI ELITE

    Trim : ALL OPTIONS ELITE

    Engine : 1.9 CDTI 150

    Year : 2005

    Mileage : 140,000

    Default

    Have you checked the swirl bar is working as it should?

  8. #8
    Regular Member
    Join Date
    Feb 2012
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SIGNUM 1.9 CDTI ELITE

    Trim : ALL OPTIONS ELITE

    Engine : 1.9 CDTI 150

    Year : 2005

    Mileage : 140,000

    Default

    tried unplugging the EGR and taking it for a run?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra Elite CDTI150
    By Matt_Bankier in forum Vehicle Diaries
    Replies: 23
    Last Post: 17th September 2013, 23:03
  2. Vectra 1.9 cdti150 ECU location...
    By toadie83 in forum Engine & Drivetrain
    Replies: 3
    Last Post: 10th January 2012, 14:59
  3. Vectra CDTI150 ECU Remapping
    By ShaunsVectra in forum Diesel Engine related
    Replies: 7
    Last Post: 21st January 2010, 17:10
  4. J** OGY vectra cdti150 sri black
    By vectra666 in forum Spotted or put a flyer on a Vectra C/Signum or Insignia?
    Replies: 2
    Last Post: 19th January 2009, 22:10
  5. 205hp from CDTi150
    By POAH in forum Vectra C / Signum Car Chat
    Replies: 23
    Last Post: 4th December 2006, 13:57

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •