User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Possible rear brake problem

  1. #1
    Regular Member justin32's Avatar
    Join Date
    Aug 2011
    Location
    Basingstoke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c SRI Facelift

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2006

    Default Possible rear brake problem

    I changed my rear pads last friday,all went well and didnt take long at all but i did notice that when the pads and carrier were bolted back on they seemed kind of loose and i could wobble them.also the old pads i noticed that they were worn at an angle with the top of the pad slightly thinner that the bottom.

    Today ive noticed that the pads are only touching the top inch of the disc and the rest has a layer of rust on them.I did a trip of about 35 miles and on returning the rust was still there apart from the top inch of the disc.

    Is this normal and just need bedding in or is it more serious?

    Thanks

  2. #2
    Regular Member dave1419's Avatar
    Join Date
    Jun 2012
    Location
    newcastle upon tyne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    9 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : 1.8vvt

    Trim : SRi

    Engine : 1.8xer

    Year : 2008

    Mileage : 20,000

    Default

    Hello,i know this is a silly question-but the retaining springs are on the calipers [at the front],i replaced my pads recently and i noticed that the caliper moved around quite a bit without these springs fitted.before i replaced the pads i give the calipers and all the parts a good brush down and rewound the brake piston in [clockwise],i then give all the parts that needed it a coat of copper grease and it has been fine since. Hope you get sorted----Dave

  3. #3
    Regular Member justin32's Avatar
    Join Date
    Aug 2011
    Location
    Basingstoke
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra c SRI Facelift

    Trim : SRI

    Engine : 1.9 CDTI 150

    Year : 2006

    Default

    Hi Dave,
    yes the pad retainging spring were put in and fitted correctly(learnt the hard way before by not fitting them properly on thr front pads) and the slider bolts were given a smear of copper grease.

    Come to think of it i didnt notice the carrier was wobbley before i put the pad spring in so that that worry sorted lol

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Rear brake caliper problem
    By siadwel in forum Suspension, Wheels & Brakes
    Replies: 7
    Last Post: 19th July 2012, 16:37
  2. rear brake light problem, bulb ok, please help
    By circushead in forum Electrical & ICE (including SatNav)
    Replies: 11
    Last Post: 14th May 2009, 18:29
  3. new rear brake problem
    By davidjameswest in forum General Chat
    Replies: 11
    Last Post: 11th May 2009, 10:26
  4. Rear brake problem
    By LGD in forum Suspension, Wheels & Brakes
    Replies: 11
    Last Post: 23rd May 2008, 08:01
  5. rear brake problem guys
    By gaz130 in forum Suspension, Wheels & Brakes
    Replies: 4
    Last Post: 4th March 2008, 12:04

Visitors found this page by searching for:

vectra c rear brake problems

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •