User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Possible top strut mount gone

  1. #1
    Regular Member
    Join Date
    Mar 2013
    Location
    norwich norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : signum

    Trim : exclusive

    Engine : 1.9 cdti 150

    Year : 2006

    Default Possible top strut mount gone

    Hi have got a signum 1.9 cdti for the last two weeks my car has sometimes made a springing noise when turning the steering wheel.which I presumed was the top strut mount bearing on the way out.I was planning to replace this at the end of the month(payday).however whilst driving last night the noise got considerably worse.the springing noise has gone and has been replaced by a loud knocking noise.it doesn't do this when in a straight line or going over bumps but more when I turn nearly full lock in when direction it knocks about 3to or 4 times together.this noise appears when moving and when stationary as long as I am steering.its not a cv boot clicking noise.what do u guys think it might be.its coming from the drivers side.thanks

  2. #2
    Regular Member david-bell's Avatar
    Join Date
    Sep 2005
    Location
    eastlothian scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra vxr

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2008

    Mileage : 31000

    Default

    I had to replace the top mounts on my old signum it was more a grinding sound when the car was stationary using the steering lock to lock. what you you describing might be a broken spring?

  3. #3
    Regular Member
    Join Date
    Mar 2013
    Location
    norwich norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : signum

    Trim : exclusive

    Engine : 1.9 cdti 150

    Year : 2006

    Default

    Hmm could be the noise does sound like a grinding sort of noise.its really hard to describe.is it dangerous to drive as im not off work until tuesday and the car for work.are the signum suspect struts easy to remove.its a new shape 06.I haven't had a chance to look at it properly yet as was dark but using a torch I couldn't see any breaks on the spring.how do I tell if a mount has gone.if it is the mount can I replace just the bearing or the whole thing thanks for your help

  4. #4
    Regular Member david-bell's Avatar
    Join Date
    Sep 2005
    Location
    eastlothian scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra vxr

    Trim : vxr

    Engine : 2.8 v6 turbo

    Year : 2008

    Mileage : 31000

    Default

    If it is the mounts it will be fine but if its a broken spring might not be as safe. the trouble is they are exposed to all the road c..p and be come dry they are plastic my signum was 06 aswell very easy to change I'm sure this is what you need http://www.eurocarparts.com/ecp/c/Va...d74d8d4&000872

  5. #5
    Full Member
    Join Date
    Jan 2008
    Location
    Lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Hatch

    Trim : Exclusive Plus Pack

    Engine : 1.9 CDTi Z19DTH

    Year : 57

    Mileage : 100k+

    Default

    Similar noise for me - started after leaving it parked for 2 weeks - not if that's related but it had an ominous springy clanging noise when turning and then self centring was pulling one way or the other. Just jacked it up and it's a broken spring on the driver's side. It's broken near the bottom where it gets narrower. Off to consult the Haynes.

  6. #6
    Regular Member
    Join Date
    Mar 2013
    Location
    norwich norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : signum

    Trim : exclusive

    Engine : 1.9 cdti 150

    Year : 2006

    Default

    Thanks for the advice am going to drive it to work today because I work at aftermarket car parts which has a fastfit swell so will get it on a ramp and have a look at the spring

  7. #7
    Regular Member
    Join Date
    Feb 2009
    Location
    crook
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    That sounds like a broken spring.
    doesnt make no difference coz you have to take strut off to do bearing as well.
    Mine was both

  8. #8
    Full Member
    Join Date
    Jan 2008
    Location
    Lincs
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Hatch

    Trim : Exclusive Plus Pack

    Engine : 1.9 CDTi Z19DTH

    Year : 57

    Mileage : 100k+

    Default

    See above. Actually it was broken in 2 places, top and bottom. Replaced the spring but the bearings could do with replacing too I think. Only had time to do one due to the weather, I know it is supposed to be both, but the other will get done next weekend, maybe with bearings both sides too.

  9. #9
    Regular Member
    Join Date
    Feb 2009
    Location
    crook
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by vxvirgin View Post
    See above. Actually it was broken in 2 places, top and bottom. Replaced the spring but the bearings could do with replacing too I think. Only had time to do one due to the weather, I know it is supposed to be both, but the other will get done next weekend, maybe with bearings both sides too.
    Make sure you change spring on other side.
    Common fault to go at top and bottom

  10. #10
    Regular Member
    Join Date
    Mar 2013
    Location
    norwich norfolk
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : signum

    Trim : exclusive

    Engine : 1.9 cdti 150

    Year : 2006

    Default

    I couldn't get it on the ramp today but jacked it up while my girlfriend turned the steering wheel.the spring looks complete and in good condition. The spring turns freely and doesn't kick back.however the grinflding noise seems to be coming from the strut mount as if u put your ear near it I can hear thats where its coming from.so does that mean its the bearing thats gone and is it dangerous to drive until tuesday.thanks for all your replys and is there any special tools I need to remove the strut other than spring clamps

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Strut mount top plate
    By baluachrach in forum Suspension, Wheels & Brakes
    Replies: 0
    Last Post: 17th August 2012, 00:10
  2. Strut top mount bolts...
    By DNS in forum Suspension, Wheels & Brakes
    Replies: 3
    Last Post: 29th February 2012, 21:51
  3. Strut top mount noise.
    By jrh1 in forum Vectra C / Signum Car Chat
    Replies: 3
    Last Post: 29th March 2011, 14:21
  4. Strut Top Mount
    By PORKBALLS29 in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 22nd November 2010, 22:19

Visitors found this page by searching for:

vectra c top top strut mount wear

vectra strut mount

vectra c top mount worn

vectra cdti strut bearing

upper strut mount replacement vectra c

vauxhall vectra c top mount

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •