User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Vectra C 2004 Heater blower blowing cold.

  1. #1
    Regular Member
    Join Date
    Feb 2012
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Vectra C 2004 Heater blower blowing cold.

    Hiya all, I brought the car a few weeks ago and had this problem from the start, Had a water leak and did not know where it was coming from or where my water was going and as it rains all day everyday i couldn't see any on the floor, I used K-Seal and the leak has stopped.
    I only had setting 4 on the blower so i replaced the resister pack and hurray i got settings 1,2 & 3 working but it only blows cold air, when i bring the revs up over 2500rpm it goes warm (not hot) but when i ease off and revs return to normal it goes cold again, What could this be?

    Any help would be much appreciated Thankyou

    Just to add its a Vectra C, 2004 (54), 1.8 SXi

  2. #2
    Regular Member
    Join Date
    Jan 2012
    Location
    Silverstone village
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    K seal may have also sealed partially up the, heat exchange for the in cabin heater, or the water pump may be on the way out , what does the temperature gauge say ?

  3. #3
    Regular Member madmark's Avatar
    Join Date
    Feb 2008
    Location
    great yarmouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    sounds like air in the cooling system to me should be a bleed screw on the cooling system somewere at a high point also get it to the point were it blows warm and change the settings to cold and see if it changer to check the switch is working also check the pipes that go through the bulk head in the the back of the dashboard are getting hot in and out good luck hope you sort it

  4. #4
    Regular Member
    Join Date
    Feb 2012
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by mon View Post
    K seal may have also sealed partially up the, heat exchange for the in cabin heater, or the water pump may be on the way out , what does the temperature gauge say ?
    The tempreature guage is normal, Reads about 90 Degree.

  5. #5
    Regular Member
    Join Date
    Feb 2012
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by madmark View Post
    sounds like air in the cooling system to me should be a bleed screw on the cooling system somewere at a high point also get it to the point were it blows warm and change the settings to cold and see if it changer to check the switch is working also check the pipes that go through the bulk head in the the back of the dashboard are getting hot in and out good luck hope you sort it

    Cannot find a bleed nipple, Have run a hose pipe threw the 2 pipes that go threw the bulk and water comes threw, The pipes however, 1 gets hot and the other only gets luke warm and have also changes the setting from cold to warm and all seems to be working but when turned all the way to cold it knocks badly as if its trying to adjust more but it cant, when turned to hot it makes no knocking noise but can see a red clip thing move on passenger side (when glovebox taken out) and a motor working.

  6. #6
    Administrator plasma's Avatar
    Join Date
    Mar 2006
    Location
    On the Forum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    1
    Post Thanks / Like
    Mentioned
    438 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : 150

    Year : 05

    Mileage : 74000

    Default

    that is an airlock you have there, Had that on a cdti i did a complete coolant flush on. Refilled it, ran it up to temp, no cabin hot air, one feed nice and hot going through the bulk head other was cold. Coolant screw was bleed. Had to run it up and down a few times and relieve pressure from the coolant tank and eventually it gurgled, cleared itself and i added another litre of coolant
    Plasma's Tech2 services are now open and able to provide services

  7. #7
    Regular Member madmark's Avatar
    Join Date
    Feb 2008
    Location
    great yarmouth
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yes sounds like air to me aswell

  8. #8
    Regular Member SlowCoach's Avatar
    Join Date
    Jan 2012
    Location
    Houghton Le Spring
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SRI 150

    Trim : Smart and Bad!

    Engine : Z19DTH

    Year : 2008

    Mileage : 105000

    Default

    Same here, part thinks blockage part think airlock. Was thinking of tilting the car sideways on left to get it to release air out. But doubt it. Have spare matrix... BUT... Worry about water getting all over driver area!!

    Should i attempt this?? Replace matrix??

  9. #9
    Regular Member
    Join Date
    Feb 2012
    Location
    Birmingham
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by plasma View Post
    that is an airlock you have there, Had that on a cdti i did a complete coolant flush on. Refilled it, ran it up to temp, no cabin hot air, one feed nice and hot going through the bulk head other was cold. Coolant screw was bleed. Had to run it up and down a few times and relieve pressure from the coolant tank and eventually it gurgled, cleared itself and i added another litre of coolant

    Hiya, Thanks for help, Any idea how i can bleed the system, ive searched all the coolant pipes and the pipes going threw the bulk to the matrix and cannot find a bleeding screw...

  10. #10
    VIP-Member
    Join Date
    Dec 2010
    Location
    London
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats



    Engine : Z18XER


    Default

    You haven't got a bleed screw on that engine. What i would do is drain coolant from bottom of radiator and refill SLOWLY i use a small funnel so it restricts the flow, this allows the air to escape better as its filling. Once full turn heater on full and start engine until up to temp top up as necessary.Allow to cool and check level

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra LS blowing cold air only
    By andy64 in forum Vectra C / Signum Troubleshooting
    Replies: 9
    Last Post: 23rd January 2011, 18:04
  2. Vectra c heater prob only blowing warm help
    By 0114NIGEL0114 in forum Vectra C / Signum Troubleshooting
    Replies: 20
    Last Post: 3rd January 2011, 17:03
  3. Heater only blowing cold air
    By Chilie in forum Vectra C / Signum Troubleshooting
    Replies: 5
    Last Post: 23rd December 2009, 18:26
  4. Vectra C blowing cold air
    By 999bruno in forum Engine & Drivetrain
    Replies: 2
    Last Post: 19th December 2009, 12:40
  5. Heater blowing cold.
    By neilgsi in forum Electrical & ICE (including SatNav)
    Replies: 4
    Last Post: 6th December 2008, 17:48

Visitors found this page by searching for:

vectra c heater blowing cold

vectra c clicking noise from heater and only blowing cold

vectra c heater goes cold when i brake

vectra c 04 heater only blows cold

vectra c 04 heater blowing cold

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •