User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 27

Thread: 2007 cdti 150 bhp poor brake pedal ?

  1. #1
    Regular Member
    Join Date
    Jun 2012
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default 2007 cdti 150 bhp poor brake pedal ?

    Hi,im a bit confused as i have a poor brake pedal which i need to pump once to get a good bite from the brakes,took it to a guy who checked the discs and pads and said they are fine and that he thinks it may be down to the abs pump ? I asked if bleeding the system would sort it and he doesnt think it will ? Has any one heard of this fault with abs ? He couldnt remember 100% but said there is also some part at the front of the engine cover that is something to do with brakes that he changed a few years back but as said hes not sure.i dont want to change discs and pads and it still not sorted,any help guys,thanks.

  2. #2
    Regular Member owen_999's Avatar
    Join Date
    Aug 2012
    Location
    Hartshorne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRI 150

    Trim : SRI

    Engine : 1.9cdti 150

    Year : 2007

    Default

    It could be multiple thing. You've got your master cylinder just behind the bulk head the bit on the front of the engine will be the vacuum pump a then there is your abs and servo unit. Could be any of those I'm not sure which one.

    You haven't suffered from occasional lose of brakes at all as? I have but still trying to source the fault

    Dw I haven't had same fault as you just asking really

  3. #3
    New Member
    Join Date
    Jan 2013
    Location
    kent
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats





    Default

    if you pump the brake pedal a few times get a firm pressure push down if the brake pedal sinks away its probably the master cylinder

  4. #4
    Regular Member
    Join Date
    Jun 2012
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    No brake loss completely no, they work well when pumped which is why i was confused cause i thought the master cylinder but when this guy said what he said i was not so sure then.would a vauxhall diagnosis pick which parts to blame ?

  5. #5
    Regular Member
    Join Date
    Jun 2012
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by jeff workshop View Post
    if you pump the brake pedal a few times get a firm pressure push down if the brake pedal sinks away its probably the master cylinder
    Ill give that a go tomorow mate cheers.

  6. #6
    Regular Member
    Join Date
    Jun 2012
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Just been to shop and tried the pedal,when engine running i pumped pedal till hard about 4 to 5 times then held foot on pedal and it does slowly go down,when ignition of it just stays hard and doesnt move ? Would have thought engine needs to be running ? So would you say master cylinder ?thanks,carl.

  7. #7
    Regular Member
    Join Date
    Jun 2012
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Anyone else have any imput on sorting this problem out please ? Should i just replace the master cylinder and go from there ? Cheers.

  8. #8
    Regular Member owen_999's Avatar
    Join Date
    Aug 2012
    Location
    Hartshorne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRI 150

    Trim : SRI

    Engine : 1.9cdti 150

    Year : 2007

    Default

    It sounds like your master cylinder is ok. The test is when the engine is off and it should stay firm. It lowers when the engine is on due the the vacuum pump and the abs allowing more movement within the pedal. It may be worth getting the vacuum pump inspected as it might be cheaper to do this than just replacing the abs unit straight out first to learn it was wrong

  9. #9
    Regular Member
    Join Date
    Jun 2012
    Location
    Midlands
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Ok mate thankyou,is the vac pump the round gold looking thing under front of engine cover(on n/s if sat in car )?
    I think it is just googled it lol,could it be any thing to do with the two black pipes being blocked or need cleaning ? Sorry for all questions but i would like to have a go at something if i can.
    Last edited by Scoobycarl; 17th March 2013 at 13:17.

  10. #10
    Regular Member owen_999's Avatar
    Join Date
    Aug 2012
    Location
    Hartshorne
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra SRI 150

    Trim : SRI

    Engine : 1.9cdti 150

    Year : 2007

    Default

    I believe so. It look like it has a fine mesh on the flat face and is circular bolted to the top side of the engine on the passenger side.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Front brake pad problem, constant rattle until brake pedal is depressed
    By Whiteknight841 in forum Suspension, Wheels & Brakes
    Replies: 7
    Last Post: 23rd September 2014, 08:20
  2. For Sale: Vauxhall Insignia Brake Pedal Alloy Cover - SRI sports pedal cover
    By Vaux-Man-G in forum Parts for sale
    Replies: 1
    Last Post: 20th December 2012, 21:36
  3. brake pedal problem
    By Swedge in forum Suspension, Wheels & Brakes
    Replies: 1
    Last Post: 1st September 2012, 17:44
  4. Brake pedal ?
    By Denbo in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 30th March 2011, 01:47
  5. brake pedal
    By barrie m in forum Suspension, Wheels & Brakes
    Replies: 2
    Last Post: 12th February 2010, 21:21

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •