User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 5 of 5

Thread: help :-)

  1. #1
    New Member
    Join Date
    Mar 2013
    Location
    cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : life

    Engine : 1.9cdti

    Year : 05

    Default help :-)

    Hi all, new to site but could use some help.

    I have a 1.9 cdti 120 vectra and the first problem is the egr 0400 fault. this caused the engine light to come on, I took off the egr and the MAP sensor and given them a good clean.

    I then turned the engine light off and it stayed off for a whole 2 miles before coming on again, reading 0400 fault again. any ideas where the problem may lay? the egr is clean and moves freely.

    The car also randomly goes into limp mode under hard acceleration, I had a fuel pressure fault a while back but only get the 0400 now.

    Can the 0400 egr send me into limp? is the fuel pressure taken from a sensor off the rail? and would changing fuel pressure sensor open a whole new can of worms.

    Apart from going into limp mode occasionally, which turning off and on has sorted, the car drives well. I would just like to sort these issues so I can have a little more confidence in the car.

    Thanks in advance for any help you can send my way.

    Keith

  2. #2
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Is the EGR gasket sealing properly, and all EGR bolts tight, and plug securely attached?

    Usually, 0400 will NOT send the car into limp mode. Try unplugging the EGR and road-testing (Spanner will come on, followed by eml light). See if it drives any different.

  3. #3
    New Member
    Join Date
    Mar 2013
    Location
    cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : life

    Engine : 1.9cdti

    Year : 05

    Default

    I think the limp mode comes from the diesel pressure as I had that problem before the erg issue. The erg is of the type with the pipe entering from the bottom and a corrugated pipe off the end to the manifold. the gaskets were thin tin ones which I just put back in place. I didn't use any mani seal as it looked okay. I'll try unplugging it tomorrow, how should it drive unplugged?

  4. #4
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    With the EGR unplugged, the light will be on. Should not be in limp mode. And should spool up on the turbo slightly better

  5. #5
    New Member
    Join Date
    Mar 2013
    Location
    cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : life

    Engine : 1.9cdti

    Year : 05

    Default

    If I unplugged it and it drove the same, does that mean a new egr would cure the eml?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •