User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 9 of 9

Thread: no performance under 2000 revs

  1. #1
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri auto

    Engine : 1.9 cdti 150

    Year : 2008

    Mileage : 119k

    Default no performance under 2000 revs

    Right, im fed up of my car struggling to pull.away and then getting to 2k revs and really taking off.

    Car is 57 plate cdti auto sri (150). Its done 90k miles, has mas remap with decat and dpf removal. Swirl bar is in place, ive cleaned the boost sensor.

    Now, I.occassionally get diesel fumes in the cabin so possible flexi problem.
    When cold I get a whistling sound when accelerating which lasts a minute or two tgen disappears.
    Ive checked the rubber pipes near front of engine for splits and cant see any.

    Im wondering if the maf is dead? I know on my last car a similar problem was caused by the maf being duff.

    Any help please cos its driving me nuts. Also, the car had rhis problem before the mas remap.

  2. #2
    Vectra-sport Admin Dre's Avatar
    Join Date
    Dec 2009
    Location
    Vectra-sport Admin
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : VXD




    Default

    sounds like the egr valve is sticking there is a how 2 on removing it and cleaning the valve out hth

  3. #3
    Regular Member Vectra-c-SRI's Avatar
    Join Date
    May 2008
    Location
    Near Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRi

    Engine : 1.9cdti 8v (120bhp)

    Year : 2005

    Mileage : 98000
    Last edited by Vectra-c-SRI; 12th March 2013 at 23:58.

  4. #4
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri auto

    Engine : 1.9 cdti 150

    Year : 2008

    Mileage : 119k

    Default

    Thanks for the replies guys, but my egr is blanked and has supposedly been mapped out with the mas remap. So it shouldnt be the cause of my problem.

  5. #5
    Regular Member Vectra-c-SRI's Avatar
    Join Date
    May 2008
    Location
    Near Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRi

    Engine : 1.9cdti 8v (120bhp)

    Year : 2005

    Mileage : 98000

    Default

    Solenoid waste gate value ?

  6. #6
    Regular Member
    Join Date
    Sep 2010
    Location
    Milton Keynes
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : sri auto

    Engine : 1.9 cdti 150

    Year : 2008

    Mileage : 119k

    Default

    Woukdnt have a clue as to the solenoid waste gate value mate

    But ive been reading up about the boost pipes and have just ordered myself some silicon tubing so will try replacing them and see if that helps at all. .

  7. #7
    Regular Member
    Join Date
    Feb 2010
    Location
    Wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    5 Post(s)
    Tagged
    1 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : Design

    Engine : 1.9CDTi

    Year : 2005

    Mileage : Lots

    Default

    Ignore the map and blank, humour me by unplugging the EGR anyway and going for a drive. Mine was mapped/blanked off and was still causing the odd issue.

  8. #8
    Regular Member Vectra-c-SRI's Avatar
    Join Date
    May 2008
    Location
    Near Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRi

    Engine : 1.9cdti 8v (120bhp)

    Year : 2005

    Mileage : 98000

    Default

    Me personally wouldn't ever blank off egr, my turbo burst once cost me 700quid. To much heat. And blanking would put hell of a lot of pressure on the turbo

  9. #9
    Regular Member Vectra-c-SRI's Avatar
    Join Date
    May 2008
    Location
    Near Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRi

    Engine : 1.9cdti 8v (120bhp)

    Year : 2005

    Mileage : 98000

    Default

    Quote Originally Posted by chrislloydie View Post
    Woukdnt have a clue as to the solenoid waste gate value mate

    But ive been reading up about the boost pipes and have just ordered myself some silicon tubing so will try replacing them and see if that helps at all. .
    TRY THIS I had a split in the pipe and caused your prob


    http://www.vectra-c.com/forum/showth...-body-CDTI-150

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. vectra c 1.9 cdti 120 diesel judder at around 2000 revs
    By mozzer in forum Vectra C / Signum Car Chat
    Replies: 8
    Last Post: 6th April 2012, 16:14
  2. Exhaust emission light and loss of power below 2000 revs
    By craigb in forum Engine & Drivetrain
    Replies: 13
    Last Post: 14th March 2011, 15:08
  3. Jumpy at 2000 revs
    By Planner in forum Engine & Drivetrain
    Replies: 3
    Last Post: 10th June 2010, 17:41
  4. smoke at 2000 revs
    By vectra-c1000 in forum Vectra C / Signum Car Chat
    Replies: 4
    Last Post: 24th April 2008, 18:09
  5. Engine Judder 2.0 DTI at 2000 revs
    By cp123 in forum Engine & Drivetrain
    Replies: 0
    Last Post: 16th January 2008, 17:38

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •