User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 3 123 LastLast
Results 1 to 10 of 23

Thread: stuck glow plug

  1. #1
    Regular Member john norris's Avatar
    Join Date
    Jun 2012
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default stuck glow plug

    tried to change glow plugs today one was stuck used lots of penetrating fluid but the damn thing broke

    I now have a plug stuck no thread holding it in and i cant get it lose what can I do?

  2. #2
    Regular Member
    Join Date
    Feb 2012
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SIGNUM 1.9 CDTI ELITE

    Trim : ALL OPTIONS ELITE

    Engine : 1.9 CDTI 150

    Year : 2005

    Mileage : 140,000

    Default

    Maybe you can get a stud extractor on it???

    Did you get the engine really hot and up to operating temperature before attempting to remove?

  3. #3
    Regular Member
    Join Date
    Feb 2012
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SIGNUM 1.9 CDTI ELITE

    Trim : ALL OPTIONS ELITE

    Engine : 1.9 CDTI 150

    Year : 2005

    Mileage : 140,000

    Default

    ....Have you snapped the top of the plug off? or have you destroyed the threads of the actual plug hole?

  4. #4
    Regular Member john norris's Avatar
    Join Date
    Jun 2012
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    the top has snapped off and yeah it was up to 90

  5. #5
    Regular Member
    Join Date
    Feb 2012
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SIGNUM 1.9 CDTI ELITE

    Trim : ALL OPTIONS ELITE

    Engine : 1.9 CDTI 150

    Year : 2005

    Mileage : 140,000

    Default

    If you can get a stud extractor on it then that should do the trick, work the plug in and out though and a little at a time....do not spray wd40 on it as it will seize the plug in and lock it in place whilst the head is hot! Wd40 etc is a nightmare with heat or alloy! Remember to reheat the engine before trying again.

    The common reason for this happening is carbon build up around the bit of the threads that protrude through into the chamber, if you wind in and wind out often enough the carbon will loosen and fall off.....bit at a time and it/they will loosen enough and come out.......lol.....try it on a Merc!....dare you.

  6. #6
    Regular Member
    Join Date
    Feb 2012
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SIGNUM 1.9 CDTI ELITE

    Trim : ALL OPTIONS ELITE

    Engine : 1.9 CDTI 150

    Year : 2005

    Mileage : 140,000

    Default

    .....forgot to ask,

    has it snapped flush to the head? if not there are other tools that may remove it, if you have not done any stud extraction before it may be an idea to take it somewhere who do it for their living!

  7. #7
    Regular Member john norris's Avatar
    Join Date
    Jun 2012
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i have managed to move it out a little with a screw it the top and pulling up but it must be seriously full of carbon its not leaking when i start it

  8. #8
    Regular Member
    Join Date
    Feb 2012
    Location
    sheffield
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : SIGNUM 1.9 CDTI ELITE

    Trim : ALL OPTIONS ELITE

    Engine : 1.9 CDTI 150

    Year : 2005

    Mileage : 140,000

    Default

    not absolutely sure where your plug is? ....the top has snapped off? if so there should be the body still protruding?

  9. #9
    Regular Member neill's Avatar
    Join Date
    Nov 2009
    Location
    Warrington
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C estate

    Trim : SRI

    Engine : Z19DTH

    Year : 2008

    Mileage : 79000

    Default

    is the 9mm head still there

  10. #10
    Regular Member john norris's Avatar
    Join Date
    Jun 2012
    Location
    lancashire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by bladeage1 View Post
    not absolutely sure where your plug is? ....the top has snapped off? if so there should be the body still protruding?
    it has broken off just under the thread

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Stuck Glow plugs
    By signum_1.9 in forum Engine & Drivetrain
    Replies: 7
    Last Post: 25th October 2012, 09:59
  2. glow plugs stuck
    By melvyn8181 in forum Diesel Engine related
    Replies: 2
    Last Post: 8th December 2011, 21:27
  3. glow plug relay and glow plugs
    By bobk1 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 3rd September 2009, 17:02
  4. my stuck glow plug... cowboy garage....
    By fireman00067 in forum Engine & Drivetrain
    Replies: 6
    Last Post: 2nd April 2009, 07:04
  5. my stuck glow plug... cowboy garage....
    By fireman00067 in forum Introduce yourself.
    Replies: 1
    Last Post: 1st April 2009, 22:13

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •