User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: Little Help please and my story so far

  1. #1
    Regular Member keef's Avatar
    Join Date
    Jan 2013
    Location
    newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9cdti (150)

    Year : 2006

    Mileage : 160,000

    Default Little Help please and my story so far

    Hey all..ok heres a short version of my story so far.. acquired a 2006 signum 1.9 cdti (150 bhp)..full history but 160,000 miles mostly long motorway trips..last owner a friend of mine had the car from nearly new and thousands of pounds later in repairs he just got sick and wanted rid..ok so far iv replaced alternator..had the spanner light on running rough..noticed swirl flap rod was just lying there done the quick fix all the flaps were moving ok got bar back on..now the spanner light has went off..car 2 days later going into limp mode all the time..pedal test wouldnt work tried both ways..so cleaned EGR valve and boost switch and now seems to have worked..today exhaust emissions light is constantly on..spanner light is off..what could this be?is there any common problems for this light just stays on..car seems to be running ok?...also another question can glow plugs cause limp mode?.. i say this as 3 tips have snapped in head..the car starts ok..and also never had any problems just for future reference until i get them out...cheers all



  2. #2
    Regular Member
    Join Date
    Jan 2012
    Location
    Gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Have you plugged the EGR back in after cleaning it out? If left unplugged the spanner light will go after a few restarts and you will get a permanent emissions light. Car will drive fine though (in fact better!).

  3. #3
    Regular Member
    Join Date
    May 2009
    Location
    Manchester
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Sounds like sticking EGR valve. At first it stuck open (egr sticking open can feel alot like limp home mode - no power at all) and now it's stuck closed. With it stuck closed you wont have any power issues but the ECU will detect EGR malfunction and on the third start after the fault occurs the spanner light changes to the MIL. Only way to confirm is to read the code that causing the MIL.

    Glow plugs when faulty usually put the spanner light on for a few minutes after starting, then the spanner goes out. I cant see why glow plugs would cause limp home, they are not essential to running once the engine is started. They are just to preheat the cylinders to aid initial combustion.

  4. #4
    Regular Member
    Join Date
    Sep 2007
    Location
    scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    only real way is to get codes read mate .
    "tips snapped in head" ? not entirely sure what you mean here ????
    by reading codes you can pinpoint the fault , then no need for guesswork .
    cheers

  5. #5
    Regular Member keef's Avatar
    Join Date
    Jan 2013
    Location
    newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9cdti (150)

    Year : 2006

    Mileage : 160,000

    Default

    Yea plugged it back in..the light wasnt on until after i cleaned the valve..but it is plugged in right..

  6. #6
    Regular Member keef's Avatar
    Join Date
    Jan 2013
    Location
    newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9cdti (150)

    Year : 2006

    Mileage : 160,000

    Default

    the plugs had ceramic tips and had been in car from new..they just crumble off...the new ones i bought dont have ceramic tips they are all metal...

  7. #7
    Regular Member keef's Avatar
    Join Date
    Jan 2013
    Location
    newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9cdti (150)

    Year : 2006

    Mileage : 160,000

    Default

    is there any diy ways to get codes? pedal test doesnt work..?..iv also got a egr blanking plate to go in when it arrives..

  8. #8
    Regular Member keef's Avatar
    Join Date
    Jan 2013
    Location
    newcastle
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9cdti (150)

    Year : 2006

    Mileage : 160,000

    Default

    Quote Originally Posted by jonnyaykroyd View Post
    Sounds like sticking EGR valve. At first it stuck open (egr sticking open can feel alot like limp home mode - no power at all) and now it's stuck closed. With it stuck closed you wont have any power issues but the ECU will detect EGR malfunction and on the third start after the fault occurs the spanner light changes to the MIL. Only way to confirm is to read the code that causing the MIL.

    Glow plugs when faulty usually put the spanner light on for a few minutes after starting, then the spanner goes out. I cant see why glow plugs would cause limp home, they are not essential to running once the engine is started. They are just to preheat the cylinders to aid initial combustion.
    Thanks for that mate...can you tell if the egr is stuck can you free it off?also if this is the case and i fit the blanking plate do you still need the egr valve working correctly?..sorry mate im new to these engines..

  9. #9
    Regular Member XPCobra's Avatar
    Join Date
    Dec 2010
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vauxhall Vectra Hatch

    Trim : SRI with added X-Pack

    Engine : 1.9 16v 150

    Year : 2006

    Mileage : Near 100K

    Default

    Get the codes read, Becoming bored of these guessing threads.

  10. #10
    Regular Member
    Join Date
    Jan 2012
    Location
    Gloucestershire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Check the How2 for more info on cleaning the EGR, but both the sprung valve and solenoid pin need to be free moving. You should be able to move both with little effort with your hands - thumb pressure on both and they should spring back easily. If they feel gritty or they need excessive force (subjective, I know) then there's something not right.

    What blank have you ordered? The complete blank, or the Fiat/GM one with holes in?

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. A very sad story indeed..
    By macdad in forum The 'Off Topic' room
    Replies: 1
    Last Post: 11th February 2012, 22:11
  2. Sob story
    By sgmiller in forum Styling
    Replies: 5
    Last Post: 28th August 2010, 22:47
  3. GM - the story is out.
    By Ste in forum General Chat
    Replies: 23
    Last Post: 18th February 2009, 20:02
  4. Strange Story but True Story of the Cigars
    By gregc in forum Comedy & Humour
    Replies: 1
    Last Post: 21st August 2008, 14:43
  5. .....The story so far
    By kgsric in forum Quick Photo Album
    Replies: 11
    Last Post: 11th April 2007, 22:50

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •