User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: No power?

  1. #1
    Regular Member
    Join Date
    Nov 2012
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default No power?

    Hi got in the car today started no prob went to pull away and it was really slow you could walk quicker... ther was a car with a spanner in the middle of it showing on the dash,so stop the car left it for a while then started it again no prob drove the way it should anyone had this happen to them ? wat would have cost this?

  2. #2
    Regular Member ThatAudioBloke's Avatar
    Join Date
    Feb 2013
    Location
    Newcastle, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : CDTI 150

    Year : 2006

    Mileage : 103000

    Default

    Petrol or diesel? Get the codes read but if it's a diesel possibly something to do with the EGR valve?

  3. #3
    Regular Member Vectra-c-SRI's Avatar
    Join Date
    May 2008
    Location
    Near Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRi

    Engine : 1.9cdti 8v (120bhp)

    Year : 2005

    Mileage : 98000

    Default

    Had this prob on mine few times I found it was my egr. How I found it was that was I disconnected the power going to it and drove the car for about a mile.it drove like new. So pluged it back in and back to slow again so gave it 10min to get car temp up and gave it a gocod bootin on motorway. It's be 3wks now since loss of power... Mine was reallllly slow until turbo kicked in

  4. #4
    Regular Member
    Join Date
    Nov 2012
    Location
    Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by BoostPuppy View Post
    Petrol or diesel? Get the codes read but if it's a diesel possibly something to do with the EGR valve?
    Its 1.8 petrol..m8

  5. #5
    Regular Member ThatAudioBloke's Avatar
    Join Date
    Feb 2013
    Location
    Newcastle, UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    20 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi

    Engine : CDTI 150

    Year : 2006

    Mileage : 103000

    Default

    Hmm... not sure then, do the petrol ones have an EGR setup? I drink from the black pump so I don't think I'll be much use to you.

    If it put the car/spanner light on, it should have stored a fault code so it's definitely worth getting them read, I'm sure there'll be someone close with the appropriate hardware who can do it for you...

  6. #6
    Regular Member
    Join Date
    Feb 2011
    Location
    cheshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    i use to get that regular on my veccy b, it was always the throttle body needed cleaning,but not had problem with veccy c 1.8

  7. #7
    Regular Member
    Join Date
    Jan 2008
    Location
    South Wales
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Best to get the codes read. Be careful if buying a code reader, a standard EOBD / OBD-II code reader wont read the 'car & spanner' light fault codes. You need something to go in on Vauxhall's language to read these codes. You can get PC interfaces & software for around £70- cheaper than VX quoted me for a scan.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. Signum Sluggish low power, Limp mode at high power.
    By Bigg943 in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 6th June 2011, 18:55
  3. Signum Sluggish low power, Limp mode at high power.
    By Bigg943 in forum Vectra C / Signum Troubleshooting
    Replies: 0
    Last Post: 5th June 2011, 11:30
  4. Replies: 11
    Last Post: 7th January 2010, 17:50
  5. Power Steering Electrical Power Drain
    By AntB in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 1st November 2007, 16:03

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •