User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Another EGR post!!

  1. #1
    Regular Member
    Join Date
    Jul 2012
    Location
    Shropshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Another EGR post!!

    Having the no power below 2k revs trouble. However, its not all the time. it started happening a few days ago and only seemed to happen after a short blast down a duel carriage way with my foot down then would be ok again after turning off for a few hours. Happening more often now, and at random times. she will drive fine for a while then loose low end power for a few mins, then back to normal. happens constantly. It is an intermittent problem, but is happening more often. Is it the EGR needs cleaning, boost pipes changing? or anything else. Also, the EGR, Swirl flaps/manifold were change by the previous owner only 10k mile ago to there expense of £900

  2. #2
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Mine was doing the same and got worse and worse.

    Turned out that the egr solenoid was sticking now and again.

  3. #3
    Regular Member
    Join Date
    Jul 2012
    Location
    Shropshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    So just a good clean up should do the trick then?

  4. #4
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    It did with mine.

  5. #5
    Regular Member
    Join Date
    Mar 2013
    Location
    reading
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : sri

    Engine : 1.9 cdti 150

    Year : 2005

    Default

    just blocked mine off today, best thing ever done

  6. #6
    Regular Member
    Join Date
    Feb 2013
    Location
    skinningrove cleveland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra

    Trim : exclusive

    Engine : 1.9 cdti

    Year : 2006

    Mileage : 75500

    Default

    try cleaning boost sensor which is next to the egr valve , mine had same probs cleaned mine and now everything is good .

  7. #7
    Regular Member
    Join Date
    Jul 2012
    Location
    Shropshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Quote Originally Posted by hicksy View Post
    try cleaning boost sensor which is next to the egr valve , mine had same probs cleaned mine and now everything is good .
    Cleaned the EGR at my moms today, but still seemed laggy (not as bad) on the way home. Didn't do the boost sensor so could this be the problem? Swirl bar was changed about 10k miles ago and looked fine tday.

  8. #8
    Regular Member
    Join Date
    Jul 2012
    Location
    Shropshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Anyone guys?? Sorry to keep bringing it up but it its really bugging me now. The egr was cleaned today but car is still lagging under 10k revs. Still intermittent ut not as bad as was before I cleaned egr. Would it be boost sensor needs cleaning and/or pipes need changing. Would doing these things solve it or could it be summat else? as said b4, swirl br looked fine and was changed at 44000 miles. car now at 55k. Thanks in advance ppl.

  9. #9
    Regular Member lee gsi's Avatar
    Join Date
    Mar 2010
    Location
    Hampshire (Near Havant) . .Drives: Signum 1.9 CDTi
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Design

    Engine : 1.9 CDTi

    Year : 2005

    Default

    Did you see if the solenoid was nice and free by separating the 2 halfs?

  10. #10
    Regular Member
    Join Date
    Mar 2013
    Location
    reading
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : sri

    Engine : 1.9 cdti 150

    Year : 2005

    Default

    block egr off, live with the light, done mine today, mine was flat as anything upto the turbo kicks in.


    A lot more throttle response,

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. can I post yet?
    By Neil in forum The 'Off Topic' room
    Replies: 1
    Last Post: 24th November 2011, 01:03

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •