User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 8 of 8

Thread: help needed with power steering...

  1. #1
    Regular Member Vectra boy's Avatar
    Join Date
    Jul 2011
    Location
    West yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default help needed with power steering...

    hi all i hope this is in the right section sorry if its not,so i have fitted a new clutch,clutch master cylinder and clutch slave cylinder all went smooth and is back together running spot on again apart from the power steering its like driving a bus lol it was working fine before i fitted the parts above any ideas what could be the problem
    cheers ste

  2. #2
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    Check the plugs on reservoir

  3. #3
    Regular Member Vectra boy's Avatar
    Join Date
    Jul 2011
    Location
    West yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    also there is no warning light

  4. #4
    Regular Member Vectra boy's Avatar
    Join Date
    Jul 2011
    Location
    West yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    So i have checked the conections and they seem good fluid level is good i have checked the fuses there ok,
    it seems theres another fuse 80 amp any ideas where thats located

  5. #5
    Regular Member Vectra boy's Avatar
    Join Date
    Jul 2011
    Location
    West yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Anybody.?

  6. #6
    Regular Member Vectra boy's Avatar
    Join Date
    Jul 2011
    Location
    West yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Problem sorted

  7. #7
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    59 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vauxhall vivaro

    Trim : Basic

    Engine : 1.9

    Year : 2004

    Default

    What was it? May help someone else in the future

  8. #8
    Regular Member Vectra boy's Avatar
    Join Date
    Jul 2011
    Location
    West yorkshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It probably would help others in the future but since i have been on this forum i have solved all my own problems if your not in the circle you get nothing on here.
    i also put leather interior in my car like alot of others on here my airbag light is now on i dont no why but others on here do but dont like telling them who are not full members and in the so called bum licking circle
    i dont even no why i posted it on here as i knew i wouldnt get any help this forum it has been the same since it started

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 17
    Last Post: 11th March 2015, 00:55
  2. Power steering pump noise? but no steering problems
    By bennettboy in forum Engine & Drivetrain
    Replies: 2
    Last Post: 2nd November 2012, 21:33
  3. power steering pump info needed please
    By robertgsi in forum Suspension, Wheels & Brakes
    Replies: 0
    Last Post: 29th January 2011, 00:07
  4. needed!! power steering pump
    By razla01 in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 21st November 2008, 15:32

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •