User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 3 of 3

Thread: Pressure washer problems

  1. #1
    Regular Member
    Join Date
    Nov 2010
    Location
    Maidstone
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Pressure washer problems

    I have been given a Karcher 650M non runner to see if theres anything i can do with it. As im a bit of a novice when it comes to pressure washers i need a little help. Ive established that theres power getting into the unit and when the button on the front is pressed the light comes on but nothing at all is heard, not even pump trying to move, has anyone got any ideas?

  2. #2
    Regular Member
    Join Date
    Jun 2012
    Location
    North Shields
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    hi mate. sounds like a one i fixed for a mate of mine last year. some washers have a pressure switch inside . if it doesnt detect water pressure from the hose it stops the motor working ( safety feature ). dont know how confident you are at mucking about with it but the pressure swich can be bypassed and the power
    taken straight to motor but you will lose the safety feature. hth.


    cheers john

  3. #3
    Regular Member
    Join Date
    Nov 2010
    Location
    Maidstone
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Right the pressure switch was jammed tight in there with limescale so have removed it. I located micro switch, turned on mains, depressed microswitch and the motor fired into action so i know that works fine. Ive cleaned all mating surfaces in the pressure switch recess with wire wool, bit of white grease and she moved freely. Put all back together, plumbed in, she fired up, pressurised and motor shut off as it should. Then pressed the lance handle and pressurised water came out for split second then dropped off and the motor just keeps running with no pressure, any ideas?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. New Pressure Washer
    By hodge725 in forum Detailing and Car Care Discussion
    Replies: 11
    Last Post: 31st October 2012, 13:12
  2. which pressure washer to buy?
    By MURDO in forum General Chat
    Replies: 13
    Last Post: 29th March 2012, 21:47
  3. Pressure Washer
    By deanos in forum General items for sale
    Replies: 5
    Last Post: 26th January 2008, 22:43
  4. Pressure washer
    By BigP in forum Detailing and Car Care Discussion
    Replies: 7
    Last Post: 25th May 2007, 21:48

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •