User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: Engine Management Light

  1. #1
    Regular Member
    Join Date
    Oct 2006
    Location
    Northwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Engine Management Light

    Or at least the one with the spanner picture!!

    I had a 2.2 SRI DTI and this light used to come up every now and again. The turbo would die and I'd have to pull over, turn the ignition off and when it re-started the management system seemed to reset and the car was fine again, ie turbo was working!

    Now I never got around to doing anything about it because I was trading it in very soon for my V6 but last night having had it for a year and just done 550 miles of 85+ motorway driving, I tried to pull away on a motorway having been at a roundabout, so fairly vigourous accleration and it did the same to me. This time though a quick reset didnt work and having sat it on my drive for 5 minutes reading the manual, I started it again and it seemed fine and has been today on a shirt trip.

    Anyone any idea what this might be and should I be concerned?

    Cheers

  2. #2
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yes you should be concerned.. it may stay in limphome and refuse to reset.. how would that look as a PX then??...

  3. #3
    Regular Member
    Join Date
    Oct 2006
    Location
    Northwich
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Doh!!! Yeah I obviously know that much!! Anyone seen or heard of similar problem?

  4. #4
    Regular Member Gsi3.2's Avatar
    Join Date
    Jul 2005
    Location
    Technical directors office
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    it could be so many things... boost controller....

    to be honest, your best bet is to get it's fault codes read to find out for deffo...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Loss of power, Engine Management Light, Spanner Light
    By Shadrack in forum Vectra C / Signum Troubleshooting
    Replies: 6
    Last Post: 28th April 2013, 11:22
  2. Replies: 17
    Last Post: 16th August 2012, 10:07
  3. EGR Valve, Engine Management Light & Spanner Light
    By guygreen in forum Engine & Drivetrain
    Replies: 7
    Last Post: 12th December 2010, 20:09
  4. No throttle, traction control light, engine management light
    By si260188 in forum Engine & Drivetrain
    Replies: 2
    Last Post: 9th May 2010, 21:45
  5. Replies: 3
    Last Post: 28th April 2009, 19:49

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •