User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 2 of 2

Thread: Problems with the horn of my vectra c

  1. #1
    Regular Member
    Join Date
    Aug 2011
    Location
    Northern Ireland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default Problems with the horn of my vectra c

    My new car has been parked up for a few months now and when i have went to get it up and running i connected the new battery, but when i got in and started the car and i turn the steering wheel the horn sounds, then i turn the other way and it sounds again, tho if you put a bit of pressure on the steering wheel it stops and when you let pressure off it sounds again,

    Anyone any ideas?

  2. #2
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    CIM problem maybe? Or a loose connection behind the steering wheel?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Vectra horn not working
    By Mark Curran in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 9th July 2012, 12:54
  2. Steering wheel change problems. No horn
    By Mick B in forum Electrical & ICE (including SatNav)
    Replies: 3
    Last Post: 10th June 2011, 21:28
  3. Horn & Wiper problems
    By Samdy Gray in forum Electrical & ICE (including SatNav)
    Replies: 2
    Last Post: 29th April 2010, 20:06
  4. vectra 3.2 2005 Horn Randomly stops working? Help..
    By vec3.2 in forum Vectra C / Signum Car Chat
    Replies: 9
    Last Post: 24th August 2009, 23:10
  5. Help! Alarm/Horn problems!
    By Russ3.2GSI in forum Electrical & ICE (including SatNav)
    Replies: 22
    Last Post: 18th November 2005, 17:08

Visitors found this page by searching for:

vectra c horn

https:www.vectra-c.comforumshowthread.php181669-Problems-with-the-horn-of-my-vectra-c

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •