User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: loud bang/clunk

  1. #1
    Regular Member andy_richmond's Avatar
    Join Date
    Sep 2012
    Location
    andover
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : sri

    Engine : 2.2 dti


    Default loud bang/clunk

    have had a clunking from the front of my preface for ages, changed various bits and narrowed it down i think to top mounts. last night i pulled out of a car park, 5 mph, on full lock and bang, thought the spring had snapped, checked, all fine. drove home and the smaller clunking from that side has stopped, just the left now. top mounts letting it move plus the spring seat mod ??which mine hasnt had done. would this be about right???

  2. #2
    Regular Member
    Join Date
    Aug 2012
    Location
    Scottish Borders
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Did you get vibration when it banged?

  3. #3
    VIP-Member GSiFan's Avatar
    Join Date
    Nov 2006
    Location
    Houghton Regis, Bedfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra GSi 3.2 V6

    Trim : GSi

    Engine : Z32SE

    Year : 2003

    Mileage : 212,060

    Default

    Mine is making unspeakable sounds from front and rear at the moment. I think it is the anti-roll bar bushes that need replacing. Well, and my rear ARB drop links. I shall do the bearings and mounts too though at some point. Paul
    2003 Vauxhall Vectra GSi 3.2 V6

  4. #4
    Regular Member andy_richmond's Avatar
    Join Date
    Sep 2012
    Location
    andover
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : sri

    Engine : 2.2 dti


    Default

    No just a loud metal bang like the spring coiled up then let go. Mad me jump out my skin. Sort of a twang after but fine since. No little clunks

  5. #5
    VIP-Member GSiFan's Avatar
    Join Date
    Nov 2006
    Location
    Houghton Regis, Bedfordshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    17 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra GSi 3.2 V6

    Trim : GSi

    Engine : Z32SE

    Year : 2003

    Mileage : 212,060

    Default

    Yep. Same as mine. :-( I think mine may be a combination of issues. Paul
    2003 Vauxhall Vectra GSi 3.2 V6

  6. #6
    Regular Member andy_richmond's Avatar
    Join Date
    Sep 2012
    Location
    andover
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : sri

    Engine : 2.2 dti


    Default

    Il change the top mounts and do the spring mod. That should sort it. After that it would b wishbones for me.

  7. #7
    Regular Member
    Join Date
    Aug 2012
    Location
    Scottish Borders
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    It's top mounts, there would have been a bearing that had come out and got trapped, then when you moved the steering wheel the pressure realeased the bearing and then the spring would ping, when I took my top mounts out there where about 50% of the bearings missing.

  8. #8
    Regular Member andy_richmond's Avatar
    Join Date
    Sep 2012
    Location
    andover
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : sri

    Engine : 2.2 dti


    Default

    lovely, worth getting the kits or just the bearings

  9. #9
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800 non vvt

    Year : 2004

    Mileage : 137000

    Default

    Quote Originally Posted by andy_richmond View Post
    have had a clunking from the front of my preface for ages, changed various bits and narrowed it down i think to top mounts. last night i pulled out of a car park, 5 mph, on full lock and bang, thought the spring had snapped, checked, all fine. drove home and the smaller clunking from that side has stopped, just the left now. top mounts letting it move plus the spring seat mod ??which mine hasnt had done. would this be about right???
    Mine does same turn the wheel bang sounds as if the spring has broken it does make up jump thinking what was that

  10. #10
    Regular Member andy_richmond's Avatar
    Join Date
    Sep 2012
    Location
    andover
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats


    Trim : sri

    Engine : 2.2 dti


    Default

    horrible thing was i was pulling out of the exact same parking space my crank pulley broke and shot the belt off in november, to say i almost soiled myself would be an understatement lol

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Clunk/bang when starting
    By Mike RB in forum Engine & Drivetrain
    Replies: 5
    Last Post: 7th October 2010, 11:16
  2. bang/clunk
    By *enery* in forum Suspension, Wheels & Brakes
    Replies: 15
    Last Post: 11th June 2009, 19:41
  3. Loud clunk/bang on full lock!!
    By gtl in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 20th March 2009, 21:04
  4. Loud Clunk
    By liphook in forum Introduce yourself.
    Replies: 15
    Last Post: 16th December 2008, 21:52
  5. loud clunk
    By kristian in forum Vectra C / Signum Car Chat
    Replies: 20
    Last Post: 22nd October 2008, 16:45

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •