User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: cruise control fault, new stalk fix problem?

  1. #1
    Regular Member taffy bhoy's Avatar
    Join Date
    Aug 2008
    Location
    newport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default cruise control fault, new stalk fix problem?

    i have a problem with the cruise control on our 2003 1.8 sri. its not something i use often, but would like it working properly.
    the fault seems to be with the top button on the stalk, it works intermitantly, ie i need to press it between 5-10 times before it works, the bottom button however works perfect, turn its on but obviously to the speed it was doing the last time, as soon as i touch the top button it cuts the cruise control off.

    so from what i can gather, the fault only lies with the top button, the bottom button and the rear long thin button work fine. i have read a few posts on here so tried the trick of putting my foot under the brake and clutch pedals to pull up to see if the switches are at fault but it makes no difference.

    is it just a simple case of getting a new (second hand) stalk and fitting it, will this sort out the problem, or does the problem lie elsewhere?

  2. #2
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    Remove the stalk, strip it and clean it. Worked a treat for me

    Took me about 15 minutes all in, following the How To on here

  3. #3
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800 non vvt

    Year : 2004

    Mileage : 145000

  4. #4
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default



    BUT, remove the stalk the proper way with a paper clip, not by just yarking it out.....!

  5. #5
    Regular Member
    Join Date
    Jan 2011
    Location
    stratford upon avon
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : vectra c

    Trim : ls

    Engine : 1800 non vvt

    Year : 2004

    Mileage : 145000

    Default

    BUT, remove the stalk the proper way with a paper clip, not by just yarking it out.....!

    correct

  6. #6
    Regular Member taffy bhoy's Avatar
    Join Date
    Aug 2008
    Location
    newport
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    yep, taken stalks out the proper way when breaking my last car, cheers, will have a go at that

  7. #7
    Regular Member mike.'s Avatar
    Join Date
    Oct 2012
    Location
    peterborough
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra

    Trim : SRi NAV

    Engine : 1.9 CDTi 120

    Year : 2005

    Default

    i am gonna try this too.i have exactly the same fault.missed my cruise control last week on my way to manchester!lol

  8. #8
    Regular Member John Bishop's Avatar
    Join Date
    Oct 2010
    Location
    Lincolnshire
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    Rear long thin button?! I only have a top and bottom.

  9. #9
    Regular Member JM53 BEL's Avatar
    Join Date
    Oct 2012
    Location
    Clackmannan, Scotland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Signum

    Trim : Elgance

    Engine : 2.0 Turbo

    Year : 2004

    Mileage : 106000

    Default

    I have this exact same problem! I find if you pull stalk out then press top button it works, so think it just a dirty connection! I am going to take stalk out and clean it. See if that works, i use my cruise control all th time, i love it especially with the miles i drive to get to work.

  10. #10
    Regular Member
    Join Date
    Jul 2011
    Location
    Leeds
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia 160

    Trim : Elite Leather Light n Sight

    Engine : 2.0 16v

    Year : 2012

    Mileage : 50k

    Default

    Search for the Selotape fix or its all a waste of time.
    I bought a new stalk and it still didnt work.
    The cause is vibration,fixed with selotape !

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Cruise control stalk
    By chrisvectra in forum Electrical & ICE (including SatNav)
    Replies: 39
    Last Post: 16th November 2013, 01:15
  2. Cruise Control Stalk
    By spennny in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 27th April 2011, 12:51
  3. cruise control stalk
    By n8sby in forum Parts for sale
    Replies: 0
    Last Post: 25th May 2010, 11:48
  4. Cruise Control problem fixed by lifting stalk
    By KevinG in forum Electrical & ICE (including SatNav)
    Replies: 6
    Last Post: 22nd May 2009, 23:26
  5. cruise control stalk
    By AL21784 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 2nd August 2008, 16:14

Visitors found this page by searching for:

opel vectra c stalk cruise

vectra c cruise control problem

https:www.vectra-c.comforumshowthread.php181287-cruise-control-fault-new-stalk-fix-problem

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •