User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 7 of 7

Thread: Another EGR valve thread but please Help ME

  1. #1
    Regular Member spikeyboi33's Avatar
    Join Date
    Jan 2013
    Location
    Ireland/Poland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Prefacelift.

    Trim : "Elite"

    Engine : 2.0dti

    Year : 2003

    Mileage : 130,000

    Default Another EGR valve thread but please Help ME

    Hi guys, i tried looking for my symptoms on the forum but couldnt find a similar thread.. just had my service done today but had a problem since yesturday which is the spanner tool came up on the dash after driving for 2 minutes after starting the car. I noticed a lag when changing gears and during accelerator work.. now the car is in limp mode because it only goes up to 3K rpms, but the boost is fine.. Whats strange is that it goes away usually after driving for a while and everything goes back to normal after driving for a while.. Now my question is is that a common thing? is it just a matter of cleaning up the egr valve or is it something worse? :/ Please help. Thanks

  2. #2
    Full Member merikiito's Avatar
    Join Date
    Apr 2007
    Location
    Northampton
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Insignia CDTi SRi NAV 160

    Trim : SRi

    Engine : A20DTH

    Year : 2009

    Mileage : 88000

    Default

    You need the codes read and it might be a good idea to post up details of your car
    Lois Griffin: Peter! You're bribing your daughter with a car?
    Peter Griffin: Ah, c'mon, Lois, isn't 'bribe' just another word for 'love'?

  3. #3
    Regular Member spikeyboi33's Avatar
    Join Date
    Jan 2013
    Location
    Ireland/Poland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Prefacelift.

    Trim : "Elite"

    Engine : 2.0dti

    Year : 2003

    Mileage : 130,000

    Default

    Quote Originally Posted by merikiito View Post
    You need the codes read and it might be a good idea to post up details of your car
    Sorry the car is a 2003 2.0dti. The error was about the EGR valve but i don't member what it was and dont have a GM tool to scan the errors with.

  4. #4
    Regular Member spikeyboi33's Avatar
    Join Date
    Jan 2013
    Location
    Ireland/Poland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Prefacelift.

    Trim : "Elite"

    Engine : 2.0dti

    Year : 2003

    Mileage : 130,000

    Default

    Not only that but when the engine sit's for a while and i try to start it, the car makes a very weird, sort of dry sound then cranks a few times and then actualy starts.. when i turn it off and turn back on its all good and starts after first crank...

  5. #5
    Regular Member Vectra-c-SRI's Avatar
    Join Date
    May 2008
    Location
    Near Glasgow
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C

    Trim : SRi

    Engine : 1.9cdti 8v (120bhp)

    Year : 2005

    Mileage : 98000

    Default

    have you tryed unpluging it and drive see if its any better, drove for 5miles with it off, just so i knew it was the egr .

  6. #6
    Regular Member spikeyboi33's Avatar
    Join Date
    Jan 2013
    Location
    Ireland/Poland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Prefacelift.

    Trim : "Elite"

    Engine : 2.0dti

    Year : 2003

    Mileage : 130,000

    Default

    Will do that today, but im starting to think the problem with the startup is a battery fault since i bought it second hand and i replaced it with the old one during the service.

  7. #7
    Regular Member spikeyboi33's Avatar
    Join Date
    Jan 2013
    Location
    Ireland/Poland
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra C Prefacelift.

    Trim : "Elite"

    Engine : 2.0dti

    Year : 2003

    Mileage : 130,000

    Default

    So i tried removing the EGR yesterday and the car ran a lot smoother. I also could be reved over 3k not a bother. Now i tried charging the battery last night but it proved unsuccessful.. Car is still making a weird cranking sound, its like its not turning over for a while the turns over a few times and then starts.. Im only going to be able to get it to the mechanics sometime near the end of the week since im waiting for a rear right calliper.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Brake servo Valve (one way valve)
    By Tank988 in forum Suspension, Wheels & Brakes
    Replies: 5
    Last Post: 29th October 2012, 19:48
  2. Stripped thread(EGR Valve)
    By justin32 in forum Engine & Drivetrain
    Replies: 6
    Last Post: 27th December 2011, 19:04
  3. Another egr valve thread ;)
    By durham4416 in forum Vectra C / Signum Car Chat
    Replies: 0
    Last Post: 14th January 2011, 15:53
  4. Bring back the Krays (thread split from scam thread)
    By VauxVeteran in forum General Chat
    Replies: 14
    Last Post: 26th July 2006, 09:58

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •