User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Low mpg, cdti 120

  1. #1
    Regular Member Learch's Avatar
    Join Date
    Jan 2013
    Location
    Chester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default Low mpg, cdti 120

    I've got an 04 120 cdti and I'm struggling to get just over 40mpg out of it. I know it needs a thermostat and the mpg wasn't that bad until the eml came on the other week. I had it read and it was a boost sensor deficiency, inactive, so cleared it and replaced a perished vacuum hose. I've taken my tuning box off but it's still struggling to get 45 mpg. Could the boost converter valve by the slam panel be knackered and could this cause excessive fuel usage?

  2. #2
    Regular Member Learch's Avatar
    Join Date
    Jan 2013
    Location
    Chester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Anyone?

  3. #3
    Full Member
    Join Date
    Dec 2010
    Location
    London
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    Thermostat can affect mpg

  4. #4
    Regular Member Learch's Avatar
    Join Date
    Jan 2013
    Location
    Chester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Well I know it needs doing so ill try and get round to changing both just to be sure. Thanks for confirming what I thought.

  5. #5
    Regular Member frasedeb's Avatar
    Join Date
    Mar 2009
    Location
    hull
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Mine only averages 40-43mpg (taxi), thought it was normal. Up to 55mpg at 70mph on a run though, urban mpg not so great on these cars, a bit heavy i think.

  6. #6
    Regular Member Learch's Avatar
    Join Date
    Jan 2013
    Location
    Chester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by frasedeb View Post
    Mine only averages 40-43mpg (taxi), thought it was normal. Up to 55mpg at 70mph on a run though, urban mpg not so great on these cars, a bit heavy i think.
    That sounds like mine. Was very good on a 300 mile round trip but doing 40 miles to work and back every day it seems lower that expected. I'm using about half a tank to do 250 miles

  7. #7
    Regular Member frasedeb's Avatar
    Join Date
    Mar 2009
    Location
    hull
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Learch View Post
    That sounds like mine. Was very good on a 300 mile round trip but doing 40 miles to work and back every day it seems lower that expected. I'm using about half a tank to do 250 miles
    I didn't add that my thermostat also needs doing but still find 40-43 mpg is poor. Used to get 60mpg average out of my previous picasso 1.6hdi but the vec is a far better drive.

  8. #8
    Regular Member Learch's Avatar
    Join Date
    Jan 2013
    Location
    Chester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by frasedeb View Post
    I didn't add that my thermostat also needs doing but still find 40-43 mpg is poor. Used to get 60mpg average out of my previous picasso 1.6hdi but the vec is a far better drive.

    Well I managed to do my stat yesterday, not the easiest job as someone at vauxhall decided to make the bottom bolt a stud for the egr system. I also did my egr blank while I had it out, temp gauge actually works now and the stat started to open so ill see by next week Thursday if its any better on fuel.

  9. #9
    Regular Member Vectra-c-SRI's Avatar
    Join Date
    May 2008
    Location
    Near Glasgow
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Where is the temp sensor you changed can't find it lol (120bhp)

  10. #10
    Regular Member Learch's Avatar
    Join Date
    Jan 2013
    Location
    Chester
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Vectra-c-SRI View Post
    Where is the temp sensor you changed can't find it lol (120bhp)
    Didn't notice you had replied, sorry mate. The temp sensor is in the thermostat housing. The stat was a right pain in the arse to change. If you take the engine cover off and then look down the right hand side of the engine, between the boost pipe and the head but lower down you'll see the stat, there should be 3 smaller pipes, a larger one and the sensor there.

    I ended up changing the leak off pipes and fuel filter and its up to 46-48 mpg now so I'm happy with it for now. Would still be nice to be getting 50+ but it's better than 40-42. Over the 800 mile month it's a big enough difference.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1.9 Vectra CDTi 150 VS 2.0 CDTi 160 insignia Sri
    By Derek Mc in forum Vectra C / Signum Car Chat
    Replies: 16
    Last Post: 12th May 2011, 11:38
  2. Weird noise from Signum CDTI 1.9 CDTI (150)
    By oneightycd in forum Diesel Engine related
    Replies: 1
    Last Post: 22nd June 2007, 22:27
  3. CDTi 120bhp Vs CDTi 150bp
    By bennyk in forum Diesel Engine related
    Replies: 25
    Last Post: 6th December 2006, 23:45

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •