User Tag List

Thanks Thanks:  0
Likes Likes:  0
Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: seriously worried

  1. #1
    Regular Member
    Join Date
    May 2012
    Location
    wirral
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default seriously worried

    hi all , ive got 1.9 sri 150 cdti and last few days its been really struggling when i pull off upto about 2k revs then all power is normal especially in second gear its actually getting dangerous pulling out on some junctions as lack of power until hit about 2.5 k, tonight the car/spanner light is staying on and also the engine management light has now also come on permanently ,ive read a few posts and not sure if im looking at egr valve or inlet manifold ? ive checked the swirl rod and its still connected but i do have a build up of sludge/oil on the far right side of rod , i was thinking can i just disconnect the egr valve and see if it drives ok ?
    any replies appreciated

  2. #2
    On a Sabbatical
    Join Date
    Jul 2011
    Location
    UK
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    This sounds like a split vacuum hose or intercooler hose. At the front of the engine ul see some small thin hoses at the right of the engine near the battery next to radiator those are vacuum check the bends for splits. The intercooler one is the big thick one between the engine and battery

    Either that or u have a blocked Egr try cleaning it
    Last edited by marc vectra sri; 29th January 2013 at 20:43.

  3. #3
    Regular Member
    Join Date
    May 2012
    Location
    wirral
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by marc vectra sri View Post
    This sounds like a split vacuum hose or intercooler hose. At the front of the engine ul see some small thin hoses at the right of the engine near the battery next to radiator those are vacuum check the bends for splits. The intercooler one is the big thick one between the engine and battery

    Either that or u have a blocked Egr try cleaning it
    thanks marc , i have changed those hoses about two months ago they are fine ive checked them yesterday , is there a way of knowing its egr blocked , ill just replace it rather than clean it if its that ?

  4. #4
    On a Sabbatical
    Join Date
    Jul 2011
    Location
    UK
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Cleaning it is really easy just use carb cleaner saves buying a new one also ya boost sensor next to the Egr that could need a cleaning or u have a faulty maf

  5. #5
    Regular Member
    Join Date
    May 2012
    Location
    wirral
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by marc vectra sri View Post
    Cleaning it is really easy just use carb cleaner saves buying a new one also ya boost sensor next to the Egr that could need a cleaning or u have a faulty maf
    faulty maf ? whats that mate

  6. #6
    On a Sabbatical
    Join Date
    Jul 2011
    Location
    UK
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    It on ya airfilter hose I think

  7. #7
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)

    Default

    Do you have any way of reading codes?

    what mileage has car done?

    possible faulty maf sensor.

  8. #8
    Regular Member Critch's Avatar
    Join Date
    Dec 2009
    Location
    wirral
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    21 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by mikecoz View Post
    faulty maf ? whats that mate
    Mass air flow meter.

    monitors the amount of air taken in. By measuring the resistance across a hot wire.

    The wore becomes gummed up over time so it affects the readings.

    it Can be confirmed by watching short and long term fuel trims along with maf readings at various rev ranges

  9. #9
    Regular Member
    Join Date
    May 2012
    Location
    wirral
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Default

    Quote Originally Posted by Critch View Post
    Mass air flow meter.

    monitors the amount of air taken in. By measuring the resistance across a hot wire.

    The wore becomes gummed up over time so it affects the readings.

    it Can be confirmed by watching short and long term fuel trims along with maf readings at various rev ranges
    just noticed your on the wirral , you work in a garage mate ? cheers for reply , im suprised the egr valve isnt first on everyones list

  10. #10
    Full Member
    Join Date
    Dec 2010
    Location
    London
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    StatsVehicle Info
    Post Thanks / Like
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Default

    You can unplug EGR to try light will stay on though

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Someone please help im worried!
    By dannyjpuk in forum General Chat
    Replies: 10
    Last Post: 15th February 2011, 17:03
  2. Bit worried, might be over nothing!
    By george1987 in forum Engine & Drivetrain
    Replies: 20
    Last Post: 7th April 2010, 21:29
  3. Now i'm worried
    By braveheart in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 29th January 2010, 10:26
  4. Should i be worried?
    By Si-SRI in forum Vectra C / Signum Car Chat
    Replies: 1
    Last Post: 27th January 2010, 22:41
  5. Bit worried
    By SRIRob in forum Vectra C / Signum Car Chat
    Replies: 13
    Last Post: 11th January 2010, 20:03

Visitors found this page by searching for:

Nobody landed on this page from a search engine, yet!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •