User Tag List

Thanks Thanks:  0
Likes Likes:  0
Results 1 to 4 of 4

Thread: 1.9 120 Lack of power.

  1. #1
    Regular Member
    Join Date
    Nov 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra 1.9 CDTI 120

    Trim : Energy

    Engine : 1.9 8v 120 BHP

    Year : 2004

    Mileage : 170, 000

    Default 1.9 120 Lack of power.

    Sorry about the second thread.

    Been told that after checking all the usual things the last thing to check is the VNT mechanism on the turbo. Apparently they can stick causing lack of boost.

    My problems coincided with changing the oil, I used wynns engine flush prior to the oil change. I drove it carefully the 2 miles to kwik fit. Would that knacker the VNT Mechanism ?. Would 10k boost clean it out ?.

  2. #2
    Regular Member
    Join Date
    Jun 2011
    Location
    brum
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats





    Default

    The VNT mechanism in the turbo gets coked up much like the egr and boost sensor, which would be awfully coincidental for that to go from fine to over-coked up in a 2 mile run.

    It may be possible that the engine flush as loosened some crud which is now stuck somewhere causing problems.

    There is many threads on here and other sites like this that relate to varying opinions on the using engine flush. I really want to flush my engine each time i service it, but as i don't really know if it was flushed regularly before i bought the car, i always get scared and decide not too bother because of this potential problem (although admittedly it seems extremely rare).

    General rule of thumb i believe is... unless you know the engine has been flushed from new regularly during services, flushing may cause damage and you do so at your own risk.

    Note: I'm not a mechanic or that good with this stuff, i'm not 100% sure if dislodged gunk would cause a loss of power, or whether it would only be attributed to more severe reactions.

  3. #3
    Regular Member
    Join Date
    Oct 2009
    Location
    UK
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : z

    Trim : z

    Engine : z

    Year : z

    Default

    What oil did you use?

    Check usual suspects too - boost sensor on mine looked like a half chewed up fruit pastille. Cleaned it up, and the car was transformed

    Unplug the EGR and take it for a test run. Warning light will be on though



    Kwik Fit? .... Check they haven't overfilled the oil

  4. #4
    Regular Member
    Join Date
    Nov 2012
    Location
    Derby
    Problems Posted
    0
    Problems Solved
    0
    Best Answers
    0
    Good Answers
    0
    Post Thanks / Like
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Vehicle InfoStats

    Vehicle : Vectra 1.9 CDTI 120

    Trim : Energy

    Engine : 1.9 8v 120 BHP

    Year : 2004

    Mileage : 170, 000

    Default

    Thanks for the fast replies guys.

    The car came with no history(got it cheap) and engine has done 150,000. It had been neglected so using flush was probably a bad idea. Kwik fit use mobil I believe and it was 3 quarter's full according to the dipstick.

    Cleaning the VNT part of the turbo would require removal I take it ?. Are they a ****** to get off on a 120 ?.

    Btw tried all the how 2s regarding egr etc etc even disconnected it. No different.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. lack of power
    By apache653 in forum Engine & Drivetrain
    Replies: 10
    Last Post: 16th February 2011, 11:51
  2. lack of power
    By apache653 in forum Engine & Drivetrain
    Replies: 4
    Last Post: 6th February 2011, 20:18
  3. Lack of power...
    By lightfx in forum Engine & Drivetrain
    Replies: 8
    Last Post: 20th October 2010, 14:33
  4. Lack of Power
    By juggernaut in forum Engine & Drivetrain
    Replies: 10
    Last Post: 3rd April 2010, 16:20
  5. lack of power
    By astratovectra in forum Engine & Drivetrain
    Replies: 2
    Last Post: 20th February 2010, 19:56

Visitors found this page by searching for:

vectra c stick vnt

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •